Título

×

  • Título
  • Proxima
Suricato 2.10 - Release Notes
Projeto: | Suricato TOTVS | Data da Liberação: | 07/07/2020
Produto: | Suricato | Desenvolvimento: |
Versão: | Suricato 2.10.9.1 | Homologação: |

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.

® Marcas Registradas
SURICATO, e CODIN, são marcas registradas da Telemática sistemas Inteligentes. Especificações técnicas e suas disponibilidades estão sujeitas a alterações sem aviso prévio.


Release: 2.10.9.1

Tópico:Release: 2.10.9.1

Histórico

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.

® Marcas Registradas


Histórico

A seguir serão descritas as Correções de ROTs, Implementações de RFPs, Correções de BUGs, e quaisquer outras implementações e ou melhorias que venham a está presentes nesta versão.

Tópico:Histórico

Procedimento para atualização
Correções e Melhorias
Módulos Alterados

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Procedimento para atualização

O procedimento de atualização se aplica para cliente que possuem a versão 2.10.5 ou superior do Suricato instalada.
O processo de atualização executado pelo atualizador consiste em copiar para os diretórios do Suricato, todos os arquivos que sofreram alterações,
(Ex.: Aplicações, serviços e scripts).
Para realizar a atualização deve seguir os seguintes passos:
  • 1.
    Parar os Serviços Telemática (Ex.: Suricato REP, Suricato Middleware, Telemática Gerenciador de Serviços, etc. )
  • 2.
    Realizar um Backup do diretório raiz do Suricato e do Banco de dados, por segurança.
  • 3.
    Copiar o Executável do atualizador na pasta raiz do Suricato. (Ex.: C:\Program Files\Telematica\Suricato)
  • 4.
    Executar o atualizador.
  • 5.
    Na Pasta Raiz do Suricato, acesse a pasta SQL\ AtuDB ( Ex: C:\Program Files\Telematica\Suricato\sql\AtuBD),
    onde estarão os scripts de atualização SQL.
  • 6.
    Na pasta ORACLE\ AtuDB ( Ex: C:\Program Files\Telematica\Suricato\oracle\AtuBD),
    onde estarão os scripts de atualização ORACLE.
    Executar os scripts conforme orientação no tópico Banco de dados.
  • 7.
    Realizar a configuração de conexão com banco de dados dos serviços Suricato Middleware, Applet de monitoramento.
    Obs.: Foi Implementado no SuricatoMiddleware o suricato.config.exe para realizar a configuração de
    conexão com banco de dados.
  • 8.
    iniciar os Serviços Telemática (Ex.: Conex, GerServer, Suricato REP, Suricato Middleware, SuricatoTotvsMA, SuricatoTotvsMarcacao, SuriPlayer, etc. )


Correções e Melhorias

A seguir uma relação dos itens que entraram nesta versão.

ROTs - Correção

RedMine# | Tipo | Assunto
6310 | ROT | ROT 126566_Chris Cintos_ - Solucionar o problema na procedure SP_REPDELETE executar a exclusão da um colaborador no REP mesmo o parametro SURICATO_REP como True. Eliminar a aplicação Sincronizar Tabelas REP, foi substituída pelo Suricato REP


Módulos Alterados

A seguir uma relação de serviços e aplicações que foram criadas ou alterados nesta versão.

Tópico:Módulos Alterados

Conex
Aplicações
GerServer
Suricato REP
Suricato Middleware
WebService
SuricatoTotvsMA
SuricatoTotvsMarcacao
SuriPlayer
Banco de Dados
Applet
SuricatoClient

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Conex

A seguir o serviço alterados nesta versão.

Oracle

APLICAÇÃO | VERSÃO
Conex | ConexOxx_40.00.00
Conex REP | ConexRepCrOxx_08.00.00

MSSQL

APLICAÇÃO | VERSÃO
Conex | ConxSql_40.00.03
Conex REP | ConexRepCrSql_08.00.01


Aplicações

A seguir uma relação de aplicações criadas ou alterados nesta versão.
APLICAÇÃO | VERSÃO
cnsAcessosDosColaboradores | 1.0.3.1
cnscolab | 1.0.17.1
cnsConsumoRestaurante | 1.0.8.0
cnsGrupoNotifica | 1.0.3.0
cnsLogSuri | 1.0.3.1
cnsLogSuriDetalhe | 1.0.3.1
cnsMatrizAcesso | 1.0.4.0
cnsReport | 1.0.0.1
cnsReportEmail | 1.0.0.1
cnsSolicitanteAgendamento | 1.0.3.0
cnsusuarioVisita | 1.0.4.0
cnsvisitantes | 1.0.5.0
cnsWSGLog | 1.0.0.0
cons_Consumo_Restaurante | 1.0.6.0
cons_relat_comparativo | 1.0.5.0
consAcessoVeiculoscracha | 1.0.4.0
consagendamentovisitante | 1.0.8.1
consAprovacacaoVisitasSolicitadas | 1.0.4.5
consbaixacracha | 1.0.7.0
consbaixacrachaprov | 1.0.7.0
consclockinclockout | 1.0.3.0
conscolaboradores | 1.0.16.1
consColaboradoresporVeiculos | 1.0.4.0
conscrachavisitante | 1.0.6.0
consrelclockinclockout | 1.0.4.0
consReprocessamentoPlayerBiometria | 1.0.6.0
consretornoagendavisitante | 1.0.7.1
conssaidavisitantes | 1.0.4.0
consultimasvisitas | 1.0.13.0
consVagasEstacionametosVeiculos | 1.0.4.0
ctrAgendamentoVisita | 1.0.3.0
ctrAprovadorRegrasVisitantesJSON | 1.0.3.3
ctrbaixavisitantecons | 1.0.4.0
ctrBiometria | 1.0.20.0
ctrcolaboradorparceiro | 1.0.4.0
ctrcolaboradorservidor | 1.0.4.0
ctrcolaboradorterceiro | 1.0.4.0
ctrConfiguracoesEntradaVisitantes | 1.0.9.0
ctrConfiguracoesSuri | 1.0.21.0
ctrconsacessocolaborador | 1.0.4.0
ctrEntradaVisitante | 1.0.56.0
ctrEspelhoAcesso | 1.0.8.3
ctrEstacionamentoVeiculos | 1.0.3.0
ctrFavoritosRecentes | 1.0.3.2
ctrgravahistorico | 1.0.12.0
ctrMatchOnServer | 1.0.3.0
ctropcoesentrada | 1.0.5.0
ctrReportDownload | 1.0.0.0
ctrSmartCardActiveXPorFaixa | 1.0.5.0
ctrSobre | 1.0.6.0
ctrSolicitacaoVisita | 1.0.3.0
ctrtrocacracha | 1.0.16.0
ctrWSG | 1.0.0.1
frmagendavisitante | 1.0.10.3
frmcolaborador | 1.0.67.1
frmcolaboradoresacesso | 1.0.27.0
frmColetores | 1.0.58.1
frmcrachaempregado | 1.0.21.0
frmEstacionamentoVeiculos | 1.0.3.0
frmGrupoAprovacaoUsuariosVisita | 1.0.4.0
frmGrupoNotifica | 1.0.3.0
frmPlantas | 1.0.11.1
frmPontes | 1.0.9.0
frmprecadastrocracha | 1.0.15.1
frmprecadastrocracha69cra | 1.0.15.1
frmProcessoAutomatico | 1.0.15.0
frmprocessorelatorio | 1.0.8.0
frmReport | 1.0.0.5
frmReportColumn | 1.0.0.0
frmsaidaportaria | 1.0.6.1
frmTipodeContrato | 1.0.4.0
frmtrocaescala | 1.0.9.0
frmtrocahorario | 1.0.8.0
frmusuario | 1.0.12.0
cnsConsumoRestauranteResumo | 1.0.7.0
cnsRelatorio | 1.0.5.2
cons_contador_diario | 1.0.7.0
consrestrito | 1.0.5.0
ctrchamaacessorestrito | 1.0.4.0
frmTipoRefeicao | 1.0.11.0


GerServer

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Telemática Gerenciador de Serviços | 2.10.17.9


Suricato REP

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Serviço Suricato REP | v.1.0.6.8


Suricato Middleware

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Serviço Suricato Middleware | V.1.1.13.4


WebService

A seguir uma relação de serviços e aplicações do WebService que foram criadas ou alterados nesta versão.

Tópico:WebService

Aplicação de Integração

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Aplicação de Integração

×

  • Release: 2.10.9.1
  • Histórico
  • Módulos Alterados
  • WebService
  • Aplicação de Integração
  • Anterior
  • Proxima

Aplicação de Integração

APLICAÇÃO | VERSÃO
suricato-totvs.war | suricato-totvs-1.1.4.11.war


SuricatoTotvsMA

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
SURICATO MATRIZ ACESSO | v.1.1.2.2


SuricatoTotvsMarcacao

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Suricato Totvs Marcação | v.1.0.1.1


SuriPlayer

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Suricato Player | v.2.0.9.8


Banco de Dados

A seguir serão descritas as instruções para executar os scripts de atualização, e uma relação de objetos criados, alterados ou excluídos nesta versão.

Tópico:Banco de Dados

Oracle
SQL Server

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Oracle

×

  • Release: 2.10.9.1
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • Oracle
  • Anterior
  • Proxima

Oracle

1. Instruções para execução dos scripts Oracle.
Os scripts de atualização podem ser executados de duas maneiras, somente com o usuário sys ou caso não tenha acesso, pode ser executado com o usuário suricato e telessvr.
Com usuário sys ou privilégios equivalentes
  • •
    Executar apenas o arquivo ORAAtuSys.sql
    Obs.: após executar com o usuário sys, não é necessário executar com os usuários suricato e telessvr.
    Com usuário suricato e telessvr
  • •
    Efetuar logon com usuário telessvr e executar o arquivo ORAAtuTeleSuri.sql
Ele irá pedir o nome registrado no TNSNames (conforme print abaixo), efetuará login com os devidos usuários e irá executar os arquivos:
ORAAtuTeleDDL.sql, ORAAtuTeleDML.sql, ORAAtuSuriDDL.sql, ORAAtuSuriDML.sql, ORAAtuSynoCau.sql e ORAAtuSynoUsu.sql .
Ex.:
Obs.: após executar com os usuários suricato e telessvr, não é necessário executar com o usuário sys.

Tópico:Oracle

Objetos de banco de dados alterados ou criados


Objetos de banco de dados alterados ou criados

×

  • Release: 2.10.9.1
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • Oracle
  • Objetos de banco de dados alterados ou criados
  • Anterior
  • Proxima

Objetos de banco de dados alterados ou criados

Name | Type | Schema | Ação
SP_REPDELETE | PROCEDURE | SURICATO | CREATE OR REPLACE


SQL Server

×

  • Release: 2.10.9.1
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • SQL Server
  • Anterior
  • Proxima

SQL Server

1. Instruções para execução dos scripts
Os scripts de atualização podem ser executados de duas maneiras, somente com o usuário sa ou caso não tenha acesso, pode ser executado com o usuário suricato e telessvr.
Com usuário sa ou privilégios equivalentes
  • •
    Executar os arquivos:
1 - MSSQL_DDL_ATU_TELE.sql
2 - MSSQL_DDL_ATU_SURI.sql
3 - MSSQL_DML_ATU_SURI.sql
4 - MSSQL_DML_ATU_TELE.sql
5 - PERMISSAOTELE.sql
6 - PERMISSAOSURI.sql
Obs.: após executar com o usuário sa, não é necessário executar com os usuários suricato e telessvr.
Com usuário suricato
  • •
    Efetuar logon com usuário suricato e executar os arquivos:
2 - MSSQL_DDL_ATU_SURI.sql
3 - MSSQL_DML_ATU_SURI.sql
6 - PERMISSAOSURI.sql
Com usuário telessvr
  • •
    Efetuar logon com usuário telessvr e executar o arquivo:
1 - MSSQL_DDL_ATU_TELE.sql
4 - MSSQL_DML_ATU_TELE.sql
5 - PERMISSAOTELE.sql
Obs.: após executar com os usuários suricato e telessvr, não é necessário executar com o usuário sa.

Tópico:SQL Server

Objetos de banco de dados alterados ou criados


Objetos de banco de dados alterados ou criados

×

  • Release: 2.10.9.1
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • SQL Server
  • Objetos de banco de dados alterados ou criados
  • Anterior
  • Proxima

Objetos de banco de dados alterados ou criados

Name | Type | Schema | Ação
SEM ALTERAÇÃO |  |  |


Applet

A seguir os serviços alterados nesta versão.
Aplicação | Versão
monitor.jnlp | N/A
monitor-oracle.jnlp | N/A
suricato-monitoramento.jar | 1.5.4.0
suricato-monitoramento-dll.jar | 1.5.4.0
suricato-monitoramento-libs.jar | 1.5.4.0


SuricatoClient

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
SuricatoClient | v.1.0.1.4


Release: 2.10.9.0

Tópico:Release: 2.10.9.0

Histórico

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Correções e Melhorias

A seguir uma relação dos itens que entraram nesta versão.

ROTs - Correção

RedMine# | Tipo | Assunto
5377 | ROT | ROT 267213_Saint Gobain_Relatório de Consumo de Restaurante com problemas ao tentar trazer 1 dia
5381 | ROT | ROT 268642_Flextronics_Não Envia Relatório por Email com alarmes do REP 3000
5768 | ROT | ROT 275217 - Troca de crachá não atualiza biometria
5842 | ROT | ROT 123322_TSI_Relatório de Refeitório Não Traz Informação colocando Matrícula ou Crachá e Outros 3 Itens Relacionados ao mesmo Relatório
5843 | ROT | ROT 123321_TSI_Descrição Errada da Faixa Refeição no Banco de Dados Refletindo em Informação Errada em 2 Telas do Suricato

RFPs - Implementação

RedMine# | Tipo | Assunto
5354 | RFP | [RFP 16604] - Implementar funcionalidades complementares para o BNDES - CEDSERJ
5593 | RFP | [RFP 16622] - Implementar a integração do cadastro e bloqueio de terceiros com o BancoDoc
5624 | RFP | [RFP-16636] - Implementar o processo de envio de marcação de EPI

Melhorias

RedMine# | Tipo | Assunto
5063 | Melhoria | [ScriptCase] - Implementar o relatório de Cadastramento da Matriz de Acesso
5165 | Melhoria | [Melhoria] - Implementar a funcionalidade para replicação da biometria para o Suriplayer em equipamento de Acesso
5166 | Melhoria | [Banco] - Implementar no banco de dados a replicação da biometria para o Suriplayer em equipamento de Acesso
5897 | Melhoria | [Banco] - Implementar no procedure SP_BIOMETRIA a atualização do flag de STATUS da REPEMPR002SINC quando receber um cadastro de biometria em equipamento de acesso de terceiros
5207 | Melhoria | [ScriptCase] - Solucionar o problema na tela frmcolaboradoresacesso. Ao alterar o Perfil está apresentando no canto esquerdo superior ---N
5209 | Melhoria | [RFP 16616] - Implementar funcionalidade autenticação por biometria Suprema no Server Side
5210 | Melhoria | [ScriptCase] - Implementar tela de Colaboradores a pesquisa por biometria Suprema
5211 | Melhoria | [ScriptCase] - Implementar tela de Visitantes a pesquisa por biometria Suprema
5291 | Melhoria | [ScriptCase] - Implementar no tela de Acesso Manual a pesquisa de Visitante por Biometria
5292 | Melhoria | [ScriptCase] - Implementar no tela de Acesso Manual a pesquisa de Colaborador por Biometria
5229 | Melhoria | Instalação Suricato 2.10.8 - Efetuar a troca da versão para 2.10.9
5233 | Melhoria | [ScriptCase] -Efetuar a troca da versão no Sobre do Suricato para 2.10.9
5268 | Melhoria | [ScriptCase] - Solucionar o erro de missing expression quando é efetuada a exclusão de crachá físico em Pre Cadastro de Crachá
5270 | Melhoria | [ScriptCase] - Solucionar o erro de gravação de cartões SmarCard. Apresenta erro de inconsistência para gravar a controle
5290 | Melhoria | [ScriptCase] - Alterar a tela de Cadastro de Estacionamento para compor os itens necessários para o cliente TIMS
5297 | Melhoria | [RFP - 16606] - Implementação do cliente Brasfels - Fase 2
5487 | Melhoria | [ScriptCase] - Implementar o relatório da receita federal - ClockIn - ClockOut
5488 | Melhoria | [Toledo] - Implementar a classe para a integração com o WebService Guardian {Toledo} para Inclusão e Alteração de Visitas
5489 | Melhoria | [ScriptCase] - Implementar um parametro para definir o comportamento do agendamento da visita em relação ao WorkFlow
5490 | Melhoria | [ScriptCase] - Implementar a funcionalidade de aprovadores para Visita com o esquema proposto de "E" e "OU"
5491 | Melhoria | [ScriptCase] - Implementar a funcionalidade de aprovação de visitas
5492 | Melhoria | [ScriptCase] - Implementar na tela da entrada de visitante a exibição do estada da visita quanto a sua aprovação
5493 | Melhoria | [Toledo] - Implementar o armazenamento do XML de Ida e Volta da integração com a Toledo
5876 | Melhoria | [ScriptCase] - Implementar um parametro para definir no WorkFlow que a propria pessoa pode ser aprovadora dela mesma
5304 | Melhoria | [ScriptCase] - Encontrado Erro no Relatorio de Auditoria de Ponto, padrão e do Cliente Saint Gobainn
5308 | Melhoria | Entrada de Visitante Restringir a exibição do campo motivo
5309 | Melhoria | Alteração de Input
5310 | Melhoria | Inclusão de leitura de crachá smartcard na consulta e não aplicação Controle
5311 | Melhoria | Mensagem de erro de preenchimento obrigatório da entrada de visitante
5312 | Melhoria | Inclusão de Botao de pesquisa de crachá
5313 | Melhoria | Grupo de acesso aparecendo dois campos com descrição Planta e codin
5314 | Melhoria | Informação de PIS existente na alteração do resgistro
5315 | Melhoria | Pesquisa por ramal
5316 | Melhoria | Erro na inclusão do digito no pré cadastro de crachá
5318 | Melhoria | Na ficha de colaborador, dentro da aplicação de colaboradores
5319 | Melhoria | Inclusão de ramal no agendamento de visitante
5320 | Melhoria | Consulta de colaborador - cnscolab duplicando registros.
5530 | Melhoria | Solucionar o problema na entrada de visitante descritos no corpo do item
5531 | Melhoria | Cadastro de colaboradores
5532 | Melhoria | Implementar regra de tratativas para as buscas da CnsColab
5365 | Melhoria | [Banco] - Eliminar a trigger TELESSVR.REPALARME_EI da tabela TBREPALARME. Trigger não é necessária pois foi substituída pelo SURICATOREP
5369 | Melhoria | Casa da Moeda - Implementar o envio automática do relatório de Relatório de Acesso de Colaboradores
5228 | Melhoria | [ScriptCase] - Implementar o Relatório de Acesso de Colaboradores no menu Relatório -> Consulta na Tela
5370 | Melhoria | [ScriptCase] - Implementar a configuração para geração automática do Relatório de Acesso de Colaboradores
5423 | Melhoria | [ScriptCase] - Implementar funcionalidade para configurar os alarmes para equipamentos Telematica e Terceiros
5450 | Melhoria | [Banco] - Implementar no campo Status o valor default de '31-12-1900 00:00:00' da tabela TBMARCAACCESS
5533 | Melhoria | [ScriptCase] - Alterar a funcionalidade que permita o reprocessamento do sincronismo do SuriPlayer para melhorias do processo
5546 | Melhoria | [ScriptCase] - Implementar na funcionalidade de Espelho de Ponto em Registro -> Perfil de Acesso a ordem pelo dia da semana e a exibição da data correspondente
5595 | Melhoria | [Melhoria] - Implementar o armazenamento do log do SuriPlayer no banco de dados
5597 | Melhoria | [Banco Dados] - Criar a tabela para armazenamento do log do SuriPlayer
5598 | Melhoria | [ScriptCase] - Criar o relatório do armazenamento dos logs do SuriPlayer
5596 | Melhoria | [Melhoria] - Reorganizar o Cadastro de Codin em relação aos campos do SuriPlayer
5608 | Melhoria | [Banco Dados] - Criar os campos necessários para os equipamentos do SuriPlayer
5610 | Melhoria | [ScriptCase] - Alterar o Cadastro de Codin conforme a regra em anexo a tarefa
5711 | Melhoria | [ScriptCase] - Implementar tratamento de SQL Injection na tela frmMatrizAcesso.php
5793 | Melhoria | [ScriptCase] - Trazer a implementação da ROT 244390 referente a aplicação Processo Automatico

Bugs

RedMine# | Tipo | Assunto
5892 | Bug | [ScriptCase] - Agendamento de Visita está apresentando erro de coluna ambígua depois do Workflow. Controle de WorkFlow está desabilitado nesse teste
5901 | Bug | [ScriptCase] ORACLE | Relatório de ClockIn ClockOut retorna ORA-00923: palavra-chave FROM não localizada onde esperada
5355 | Bug | [Banco] - Solucionar o erro na View VW_MATRIZ_ACESS_FULL no campo UTILBIOM para retornar 'N' quando o valor for Vazio ou NULL
5367 | Bug | [ScriptCase] - Solucionar o erro de gravação de cartões SmarCard. Apresenta erro na Gravação por Faixa
5374 | Bug | [ScriptCase] - Ao cadastrar um equipamento o campo de quantidade multipla de acessos não esta abrindo
5401 | Bug | [ScriptCase] - Não apresenta o botão de Ler SmartCard na funcionalidade de Troca de Crachá
5415 | Bug | [ScriptCase] - Solucionar o problema do sistema permitir a associar do mesmo cartão para N pessoas
5589 | Bug | [Banco] - Solucionar o problema na procedure RH_HORESC. Na falta de existencia do else na escala variável, provocava o não funcionamento da escala fixa. Ficou incorreta a alteração realizada na versão 2.10.8
5625 | Bug | [ScriptCase] frmPlantas - Sistema retorna erro de banco ao alterar registro no campo Diferença de Fuso Horário para valores acima de 999
5635 | Bug | [Banco] - Implementar na View VW_MARCACAO_TOTVS o tratamento para devolver marcações de terceiros para o DATASUL
5849 | Bug | [Banco] - Solucionar o problema com os scripts de origem da 2.10.5.5 em SQLSERVER para Banco de Dados MASTER GENERAL BIN
5850 | Bug | [Banco] Está apresentando erro de objeto existente na execução do script de atualização Oracle
5851 | Bug | [Banco] - Está apresentando a aplicação ctrMatchOnServer.php ao invés da aplicação frmcolaborador.php utilizando o banco de dados SQLSERVER
5852 | Bug | [Banco] - Não está apresentando os labels da funcionalidade de Configurações Gerais de Sistema
5854 | Bug | [ScriptCase] ORACLE e MSSQL | frmprocessorelatorio - Tela não apresenta labels e combox não carregada
5855 | Bug | [ScriptCase] Divergências na tela de entrada de visitantes em relação ao Match On Server para entre o Oracle e SQL
5857 | Bug | [ScriptCase] Consulta Impressa:Controle para a Consulta de Acesso de Colaborador retorna página não encontrada
5858 | Bug | [ScriptCase] ORACLE e MSSQL | Cadastro Notificações Alarme REP - Erro ao inserir registro na tela
5859 | Bug | [ScriptCase] MSSQL | Cadastro de Usuários - Sistema retorna erro ao tentar incluir novo usuário ou alterar registros existentes
5866 | Bug | [ScriptCase] ORACLE | cnsMatrizAcesso - Erro ao consultar registros (ORA-00933: comando SQL não encerrado adequadamente)
5867 | Bug | [ScriptCase] ORACLE e MSSQL | consVagasEstacionametosVeiculos - Tela apresenta label faltante e duplicata
5868 | Bug | [ScriptCase] ORACLE e MSSQL | Usuário do grupo ADMIN tem acesso não autorizado ao navegar menu de Log Eventos Suriplayer
5869 | Bug | [ScriptCase] ORACLE e MSSQL | cons_relat_comparativo - Tela não apresenta label para empresa terceira
5870 | Bug | [ScriptCase] cons_relat_comparativo - Tela apresenta erro de banco ao tentar pesquisar registros
5875 | Bug | [ScriptCase] MSSQL e ORACLE | cnsMatrizAcesso - Tela apresenta labels faltantes
5878 | Bug | [ScriptCase] ORACLE e MSSQL | Consulta Impressa: Impressão de Relatório apresenta dois itens com mesmo nome
5879 | Bug | [ScriptCase] ORACLE | Consulta Impressa: Lista de Impressão de Relatório para ORACLE possui 4 itens ausentes em comparação com MSSQL
5883 | Bug | [ScriptCase] Consulta de Últimas Visitas apresenta campo sem label e não apresenta botão copiar
5886 | Bug | [Banco] - Solucionar o problema da falta da Trigger SITCOLETOR_ALARME na tabela TELESSVR.SITCOLETOR
5894 | Bug | [ScriptCase] MSSQL | Modelo de Relatório para Processo Automático - Não é possível editar registros
5898 | Bug | [Banco] - Script de atualização em Oracle não está alimentada a tabela TBVERSOES com as novas versões do software
5902 | Bug | [MSSQL] Erro ao executar o script de atualização 3
5912 | Bug | [ScriptCase] frmContratos - Falta definição das seguintes variáveis globais: idcolab
5925 | Bug | [ScriptCase] Invalid argument supplied for foreach()
5959 | Bug | [ScriptCase] frm_tbColab_LocalAcess - Falta definição das seguintes variáveis globais: idcolab
5963 | Bug | [ScriptCase] ctrMarcacaoAcessoManual - Falta definição das seguintes variáveis globais: idcolab
5966 | Bug | [ScriptCase] - cnsAcessosDosColaboradores não encontrado nos scripts AtuBD
5978 | Bug | [ScriptCase] ORACLE e MSSQL | cnscolab (v. 1.0.17.1) - Tela apresenta label faltante ao pesquisar por colaboradores que possuem ramais
5985 | Bug | [ScriptCase] ORACLE | cnsAcessosDosColaboradores (v. 1.0.3.1) - Erro de banco ao pesquisar registros ORA-00906: parêntese esquerdo não encontrado
5986 | Bug | [ScriptCase] ORACLE e MSSQL | cnsAcessosDosColaboradores - Aplicação sem nome de tela
5992 | Bug | [Oracle] Script - Erro ao executar script de atualização
5996 | Bug | [ScriptCase] cnsReportEmail (v. 1.0.0.1) - Consulta de Registro de Email Enviado de Processo Automático de Relatório retorna erro ao pesquisar: Invalid object name 'TBREPORTMAIL'


Aplicação de Integração

×

  • Release: 2.10.9.0
  • Histórico
  • Módulos Alterados
  • WebService
  • Aplicação de Integração
  • Anterior
  • Proxima

Aplicação de Integração

APLICAÇÃO | VERSÃO
suricato-totvs.war | suricato-totvs-1.1.4.11.war


Oracle

×

  • Release: 2.10.9.0
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • Oracle
  • Anterior
  • Proxima

Oracle

1. Instruções para execução dos scripts Oracle.
Os scripts de atualização podem ser executados de duas maneiras, somente com o usuário sys ou caso não tenha acesso, pode ser executado com o usuário suricato e telessvr.
Com usuário sys ou privilégios equivalentes
  • •
    Executar apenas o arquivo ORAAtuSys.sql
    Obs.: após executar com o usuário sys, não é necessário executar com os usuários suricato e telessvr.
    Com usuário suricato e telessvr
  • •
    Efetuar logon com usuário telessvr e executar o arquivo ORAAtuTeleSuri.sql
Ele irá pedir o nome registrado no TNSNames (conforme print abaixo), efetuará login com os devidos usuários e irá executar os arquivos:
ORAAtuTeleDDL.sql, ORAAtuTeleDML.sql, ORAAtuSuriDDL.sql, ORAAtuSuriDML.sql, ORAAtuSynoCau.sql e ORAAtuSynoUsu.sql .
Ex.:
Obs.: após executar com os usuários suricato e telessvr, não é necessário executar com o usuário sys.

Tópico:Oracle

Objetos de banco de dados alterados ou criados


Objetos de banco de dados alterados ou criados

×

  • Release: 2.10.9.0
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • Oracle
  • Objetos de banco de dados alterados ou criados
  • Anterior
  • Proxima

Objetos de banco de dados alterados ou criados

Name | Type | Schema | Ação
TBTEMPLCARGA | TABLE | SURICATO | CREATE
TBTEMPLHISTOCARGA | TABLE | SURICATO | CREATE
TBESTACVEIC | TABLE | SURICATO | CREATE
TBREPORT | TABLE | SURICATO | CREATE
TBREPORTCOLUMN | TABLE | SURICATO | CREATE
TBREPORTMAIL | TABLE | SURICATO | CREATE
TBGRUPOEMAILREP | TABLE | SURICATO | CREATE
TBEMAILREP | TABLE | SURICATO | CREATE
TBVISITLANCAAPROV | TABLE | SURICATO | CREATE
TBHISTOVISITAPROV | TABLE | SURICATO | CREATE
TBESVISITWSG | TABLE | SURICATO | CREATE
TBLOGSURICOMAN | TABLE | SURICATO | CREATE
TBLOGSURIDETAL | TABLE | SURICATO | CREATE
TBTEMPL | TABLE | SURICATO | ALTER
TBTIPOLEITO | TABLE | SURICATO | ALTER
TBTEMPLCARGA | TABLE | SURICATO | ALTER
TBESTACVEIC | TABLE | SURICATO | ALTER
TBPROCEAUTOM | TABLE | SURICATO | ALTER
TBREPORT | TABLE | SURICATO | ALTER
TBREPORTCOLUMN | TABLE | SURICATO | ALTER
TBREPORTMAIL | TABLE | SURICATO | ALTER
TBRELAT | TABLE | SURICATO | ALTER
TBGRUPOEMAILREP | TABLE | SURICATO | ALTER
TBEMAILREP | TABLE | SURICATO | ALTER
TBAGENDVISIT | TABLE | SURICATO | ALTER
TBUSUAR | TABLE | SURICATO | ALTER
TBVISITLANCAAPROV | TABLE | SURICATO | ALTER
TBHISTOVISITAPROV | TABLE | SURICATO | ALTER
TBMARCAACESS | TABLE | SURICATO | ALTER
TBESVISITWSG | TABLE | SURICATO | ALTER
TBPLAYER | TABLE | SURICATO | ALTER
TBLOGSURICOMAN | TABLE | SURICATO | ALTER
TBLOGSURIDETAL | TABLE | SURICATO | ALTER
SOBREPOSICAOCRACHA | FUNCTION | SURICATO | ALTER
INSTRCHAVEXT | FUNCTION | SURICATO | CREATE OR REPLACE
SOBREPOSICAOCRACHA | FUNCTION | SURICATO | CREATE OR REPLACE
SP_BIOMETRIA | PROCEDURE | SURICATO | CREATE OR REPLACE
SP_BIOMETRIA_JOB | PROCEDURE | SURICATO | CREATE OR REPLACE
SP_BIOMETRIA | PROCEDURE | SURICATO | CREATE OR REPLACE
TBHISTOCRACH_EI | TRIGGER | SURICATO | CREATE OR REPLACE
TBHISTOCRACH_EU | TRIGGER | SURICATO | CREATE OR REPLACE
TBHISTOCRACH_SI | TRIGGER | SURICATO | CREATE OR REPLACE
TBHISTOCRACH_SU | TRIGGER | SURICATO | CREATE OR REPLACE
TRG_TBGRUPOEMAILREP_INSERT | TRIGGER | SURICATO | CREATE OR REPLACE
TRG_TBEMAILREP_INSERT | TRIGGER | SURICATO | CREATE OR REPLACE
TRG_TBLOGSURICOMAN_INSERT | TRIGGER | SURICATO | CREATE OR REPLACE
TRG_TBLOGSURIDETAL_INSERT | TRIGGER | SURICATO | CREATE OR REPLACE
VBIOMETRIAMATCHONSERVER | VIEW | SURICATO | CREATE OR REPLACE
VHISTORICOCRACHA | VIEW | SURICATO | CREATE OR REPLACE
VHISTORICOCRACHABIOMETRIA | VIEW | SURICATO | CREATE OR REPLACE
VHISTORICOCRACHAVISITANTE | VIEW | SURICATO | CREATE OR REPLACE
VHISTORICOCRACHAVISITANTEBIO | VIEW | SURICATO | CREATE OR REPLACE
VMARCAACES | VIEW | SURICATO | CREATE OR REPLACE
VW_MATRIZ_ACESS_FULL | VIEW | SURICATO | CREATE OR REPLACE
V_SURICATO_EMAIL | VIEW | SURICATO | CREATE OR REPLACE
VSOLICITANTE_APROVADOR | VIEW | SURICATO | CREATE OR REPLACE
V_SOLICITACAO_VISIT | VIEW | SURICATO | CREATE OR REPLACE
VCONSULTACOLABORADOR | VIEW | SURICATO | CREATE OR REPLACE
VW_MARCACAO_TOTVS | VIEW | SURICATO | CREATE OR REPLACE
VCLOCKINCLOKOUT | VIEW | SURICATO | CREATE OR REPLACE
VTOTALREFEICOESDETALHADO | VIEW | SURICATO | CREATE OR REPLACE
VIEW_COMPARATIVO_ERP | VIEW | SURICATO | CREATE OR REPLACE
REPADNSR001 | TABLE | TELESSVR | CREATE
REPLASTCOM | TABLE | TELESSVR | CREATE
REPAUTOBIOF | TABLE | TELESSVR | ALTER
REPAUXEMPR | TABLE | TELESSVR | ALTER
AntePrep2_ROutrosBios | PROCEDURE | TELESSVR | CREATE OR REPLACE
ANTEPREP3_RSAGEM | PROCEDURE | TELESSVR | CREATE OR REPLACE
AntePrep3_RTsi1 | PROCEDURE | TELESSVR | CREATE OR REPLACE
P_RepGerDigital3 | PROCEDURE | TELESSVR | CREATE OR REPLACE
Prep_RepAuto5 | PROCEDURE | TELESSVR | CREATE OR REPLACE
Prep_RepDigit3 | PROCEDURE | TELESSVR | CREATE OR REPLACE
trata2_RepOutrosBios | PROCEDURE | TELESSVR | CREATE OR REPLACE
trata3_RepSagem | PROCEDURE | TELESSVR | CREATE OR REPLACE
trata3_Reptsi1 | PROCEDURE | TELESSVR | CREATE OR REPLACE
sqlatu_geral4 | FUNCTION | TELESSVR | CREATE OR REPLACE
sqlfinal_h | FUNCTION | TELESSVR | CREATE OR REPLACE
sqlh | FUNCTION | TELESSVR | CREATE OR REPLACE
sqller_RautoExclDigit3 | FUNCTION | TELESSVR | CREATE OR REPLACE
sqller_RautoLoadDigit3 | FUNCTION | TELESSVR | CREATE OR REPLACE
sqlload_l | FUNCTION | TELESSVR | CREATE OR REPLACE
sqlload_Rl | FUNCTION | TELESSVR | CREATE OR REPLACE
sqlpreph | FUNCTION | TELESSVR | CREATE OR REPLACE
sqlproc_dadosfunc2 | FUNCTION | TELESSVR | CREATE OR REPLACE
sqlproc_icardp | FUNCTION | TELESSVR | CREATE OR REPLACE
sqlrep_autoExc3 | FUNCTION | TELESSVR | CREATE OR REPLACE
sqlrep_fimExcAuto3 | FUNCTION | TELESSVR | CREATE OR REPLACE
sqlrhora_gerbiof2 | FUNCTION | TELESSVR | CREATE OR REPLACE
sqlrperm_novocomando | FUNCTION | TELESSVR | CREATE OR REPLACE
G3G5_P_GERDIGITAL4 | PROCEDURE | TELESSVR | CREATE OR REPLACE
sqlgrava_rep5interj | PROCEDURE | TELESSVR | CREATE OR REPLACE
sqlrepPto_interj2 | PROCEDURE | TELESSVR | CREATE OR REPLACE
trata3_palmv | PROCEDURE | TELESSVR | CREATE OR REPLACE
trata4_sagem | PROCEDURE | TELESSVR | CREATE OR REPLACE
trata4_tsi1 | PROCEDURE | TELESSVR | CREATE OR REPLACE
sitcoletor_alarme | TRIGGER | TELESSVR | CREATE OR REPLACE
TRATA3_PALMV | SYNONYM | CAUSU | CREATE
TRATA4_SAGEM | SYNONYM | CAUSU | CREATE
TRATA4_TSI1 | SYNONYM | CAUSU | CREATE
G3G5_P_GERDIGITAL4 | SYNONYM | CAUSU | CREATE
SQLRHORA_GERBIOF2 | SYNONYM | CAUSU | CREATE
PREP_REPAUTO5 | SYNONYM | CAUSU | CREATE
ANTEPREP2_ROUTROSBIOS | SYNONYM | CAUSU | CREATE
ANTEPREP3_RSAGEM | SYNONYM | CAUSU | CREATE
ANTEPREP3_RTSI1 | SYNONYM | CAUSU | CREATE
PREP_REPDIGIT3 | SYNONYM | CAUSU | CREATE
TRATA2_REPOUTROSBIOS | SYNONYM | CAUSU | CREATE
TRATA3_REPSAGEM | SYNONYM | CAUSU | CREATE
TRATA3_REPTSI1 | SYNONYM | CAUSU | CREATE
P_REPGERDIGITAL3 | SYNONYM | CAUSU | CREATE
SQLATU_GERAL4 | SYNONYM | USUTCP01 | CREATE
SQLLOAD_LISTADIG4 | SYNONYM | USUTCP01 | CREATE
SQLREPPTO_INTERJ2 | SYNONYM | USUTCP01 | CREATE
SQLGRAVA_REP5INTERJ | SYNONYM | USUTCP01 | CREATE
SQLLER_RAUTOLOADDIGIT3 | SYNONYM | USUTCP01 | CREATE
SQLLER_RAUTOEXCLDIGIT3 | SYNONYM | USUTCP01 | CREATE
SQLREP_AUTOINS3 | SYNONYM | USUTCP01 | CREATE
SQLREP_AUTOEXC3 | SYNONYM | USUTCP01 | CREATE
SQLPROC_ICARDPIS2 | SYNONYM | USUTCP01 | CREATE
SQLPREPHIST_RSTF | SYNONYM | USUTCP01 | CREATE
SQLFINAL_HISTRSTF | SYNONYM | USUTCP01 | CREATE
SQLHIST_RFUNC2 | SYNONYM | USUTCP01 | CREATE
SQLHIST_RFUNCINME | SYNONYM | USUTCP01 | CREATE
SQLRPERM_NOVOCOMANDO | SYNONYM | USUTCP01 | CREATE
SQLHIST_RBIO3 | SYNONYM | USUTCP01 | CREATE
SQLREP_FIMEXCAUTO3 | SYNONYM | USUTCP01 | CREATE
SQLLOAD_RLISTADIG3 | SYNONYM | USUTCP01 | CREATE


SQL Server

×

  • Release: 2.10.9.0
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • SQL Server
  • Anterior
  • Proxima

SQL Server

1. Instruções para execução dos scripts
Os scripts de atualização podem ser executados de duas maneiras, somente com o usuário sa ou caso não tenha acesso, pode ser executado com o usuário suricato e telessvr.
Com usuário sa ou privilégios equivalentes
  • •
    Executar os arquivos:
1 - MSSQL_DDL_ATU_TELE.sql
2 - MSSQL_DDL_ATU_SURI.sql
3 - MSSQL_DML_ATU_SURI.sql
4 - MSSQL_DML_ATU_TELE.sql
5 - PERMISSAOTELE.sql
6 - PERMISSAOSURI.sql
Obs.: após executar com o usuário sa, não é necessário executar com os usuários suricato e telessvr.
Com usuário suricato
  • •
    Efetuar logon com usuário suricato e executar os arquivos:
2 - MSSQL_DDL_ATU_SURI.sql
3 - MSSQL_DML_ATU_SURI.sql
6 - PERMISSAOSURI.sql
Com usuário telessvr
  • •
    Efetuar logon com usuário telessvr e executar o arquivo:
1 - MSSQL_DDL_ATU_TELE.sql
4 - MSSQL_DML_ATU_TELE.sql
5 - PERMISSAOTELE.sql
Obs.: após executar com os usuários suricato e telessvr, não é necessário executar com o usuário sa.

Tópico:SQL Server

Objetos de banco de dados alterados ou criados


Objetos de banco de dados alterados ou criados

×

  • Release: 2.10.9.0
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • SQL Server
  • Objetos de banco de dados alterados ou criados
  • Anterior
  • Proxima

Objetos de banco de dados alterados ou criados

Name | Type | Schema | Ação
ANTEPREP2_ROUTROSBIOS | PROCEDURE | TELESSVR | CREATE
ANTEPREP3_RSAGEM | PROCEDURE | TELESSVR | CREATE
ANTEPREP3_RTSI1 | PROCEDURE | TELESSVR | CREATE
G3G5_P_GERDIGITAL4 | PROCEDURE | TELESSVR | CREATE
P_REPGERDIGITAL3 | PROCEDURE | TELESSVR | CREATE
PREP_REPAUTO5 | PROCEDURE | TELESSVR | CREATE
PREP_REPDIGIT3 | PROCEDURE | TELESSVR | CREATE
SQLAPOS_DATAHORA6 | PROCEDURE | TELESSVR | CREATE
SQLATU_GERAL4 | PROCEDURE | TELESSVR | CREATE
SQLAVISA_CPBB_NOVELL_TCP | PROCEDURE | TELESSVR | CREATE
SQLBUSCA_OMOK_BIOMET2 | PROCEDURE | TELESSVR | CREATE
SQLBUSCA_SAGEM_BIOMET2 | PROCEDURE | TELESSVR | CREATE
SQLBUSCA_TSI1_BIOMET2 | PROCEDURE | TELESSVR | CREATE
SQLBUSCA_VERI_BIOMET2 | PROCEDURE | TELESSVR | CREATE
SQLCON_COACAO_OMOKX2 | PROCEDURE | TELESSVR | CREATE
SQLCON_COACAO_SAGEMX2 | PROCEDURE | TELESSVR | CREATE
SQLCON_COACAO2_TSI1 | PROCEDURE | TELESSVR | CREATE
SQLCON_VIVA | PROCEDURE | TELESSVR | CREATE
SQLFINAL_HISTRSTF | PROCEDURE | TELESSVR | CREATE
SQLGRAVA_REP5INTERJ | PROCEDURE | TELESSVR | CREATE
SQLHIST_RBIO3 | PROCEDURE | TELESSVR | CREATE
SQLHIST_RFUNC2 | PROCEDURE | TELESSVR | CREATE
SQLHIST_RFUNCINME | PROCEDURE | TELESSVR | CREATE
SQLLER_RAUTOEXCLDIGIT3 | PROCEDURE | TELESSVR | CREATE
SQLLER_RAUTOLOADDIGIT3 | PROCEDURE | TELESSVR | CREATE
SQLLOAD_LISTADIG4 | PROCEDURE | TELESSVR | CREATE
SQLLOAD_RLISTADIG3 | PROCEDURE | TELESSVR | CREATE
SQLPREPHIST_RSTF | PROCEDURE | TELESSVR | CREATE
SQLPROC_DADOSFUNC2 | PROCEDURE | TELESSVR | CREATE
SQLPROC_ICARDPIS2 | PROCEDURE | TELESSVR | CREATE
SQLRAVISA_CPBB_NOVELL_TCP | PROCEDURE | TELESSVR | CREATE
SQLRCON_SAGEM_DIGITAL3 | PROCEDURE | TELESSVR | CREATE
SQLRCON_TSI1_DIGITAL3 | PROCEDURE | TELESSVR | CREATE
SQLRCON_VIVA | PROCEDURE | TELESSVR | CREATE
SQLREP_AUTOEXC3 | PROCEDURE | TELESSVR | CREATE
SQLREP_AUTOINS3 | PROCEDURE | TELESSVR | CREATE
SQLREP_FIMEXCAUTO4 | PROCEDURE | TELESSVR | CREATE
SQLREP_FIMINSAUTO3 | PROCEDURE | TELESSVR | CREATE
SQLREPPTO_INTERJ2 | PROCEDURE | TELESSVR | CREATE
SQLRHORA_GERBIOF2 | PROCEDURE | TELESSVR | CREATE
SQLRPERM_NOVOCOMANDO | PROCEDURE | TELESSVR | CREATE
TRATA2_REPOUTROSBIOS | PROCEDURE | TELESSVR | CREATE
TRATA3_PALMV | PROCEDURE | TELESSVR | CREATE
TRATA3_REPSAGEM | PROCEDURE | TELESSVR | CREATE
TRATA3_REPTSI1 | PROCEDURE | TELESSVR | CREATE
TRATA4_SAGEM | PROCEDURE | TELESSVR | CREATE
TRATA4_TSI1 | PROCEDURE | TELESSVR | CREATE
REPADNSR001 | TABLE | TELESSVR | CREATE
REPLASTCOM | TABLE | TELESSVR | CREATE
SITCOLETOR_ALARME | TRIGGER | TELESSVR | CREATE
REPAUXEMPR_IND1 | UNIQUE INDEX | TELESSVR | CREATE
REPAUXEMPR_IND2 | UNIQUE INDEX | TELESSVR | CREATE
REPLASTCOM_IND1 | UNIQUE INDEX | TELESSVR | CREATE
REPAUXEMPR_IND3 | INDEX | TELESSVR | CREATE
REPAUTOBIOF | TABLE | TELESSVR | ALTER
REPAUXEMPR | TABLE | TELESSVR | ALTER
SOBREPOSICAOCRACHA | FUNCTION | SURICATO | CREATE
SP_BIOMETRIA | PROCEDURE | SURICATO | CREATE
TBHISTOCRACH_SI | PROCEDURE | SURICATO | CREATE
TBHISTOCRACH_SU | PROCEDURE | SURICATO | CREATE
TBDIFACESSOPONTOESCAL | TABLE | SURICATO | CREATE
TBEMAILREP | TABLE | SURICATO | CREATE
TBESTACVEIC | TABLE | SURICATO | CREATE
TBESVISITWSG | TABLE | SURICATO | CREATE
TBGRUPOEMAILREP | TABLE | SURICATO | CREATE
TBHISTOVISITAPROV | TABLE | SURICATO | CREATE
TBLOGSURICOMAN | TABLE | SURICATO | CREATE
TBLOGSURIDETAL | TABLE | SURICATO | CREATE
TBREPORT | TABLE | SURICATO | CREATE
TBREPORTCOLUMN | TABLE | SURICATO | CREATE
TBREPORTMAIL | TABLE | SURICATO | CREATE
TBTEMPLCARGA | TABLE | SURICATO | CREATE
TBTEMPLHISTOCARGA | TABLE | SURICATO | CREATE
TBVISITLANCAAPROV | TABLE | SURICATO | CREATE
TBTEMPL_BIOMETRIA | TRIGGER | SURICATO | CREATE
TBHISTOCRACH_EI | TRIGGER | SURICATO | CREATE
TBHISTOCRACH_EU | TRIGGER | SURICATO | CREATE
VCLOCKINCLOKOUT | VIEW | SURICATO | CREATE
V_SOLICITACAO_VISITAS | VIEW | SURICATO | CREATE
V_SURICATO_EMAIL | VIEW | SURICATO | CREATE
VBIOMETRIAMATCHONSERVER | VIEW | SURICATO | CREATE
VCONSULTACOLABORADOR | VIEW | SURICATO | CREATE
VHISTORICOCRACHA | VIEW | SURICATO | CREATE
VHISTORICOCRACHABIOMETRIA | VIEW | SURICATO | CREATE
VHISTORICOCRACHAVISITANTE | VIEW | SURICATO | CREATE
VHISTORICOCRACHAVISITANTEBIOMETRIA | VIEW | SURICATO | CREATE
VIEW_COMPARATIVO_ERP | VIEW | SURICATO | CREATE
VMARCAACES | VIEW | SURICATO | CREATE
VSOLICITANTE_APROVADOR | VIEW | SURICATO | CREATE
VTOTALREFEICOESDETALHADO | VIEW | SURICATO | CREATE
VW_MARCACAO_TOTVS | VIEW | SURICATO | CREATE
VW_MATRIZ_ACESS_FULL | VIEW | SURICATO | CREATE
TBTEMPL | TABLE | SURICATO | ALTER
TBTIPOLEITO | TABLE | SURICATO | ALTER
TBTEMPLCARGA | TABLE | SURICATO | ALTER
TBESTACVEIC | TABLE | SURICATO | ALTER
TBDIFACESSOPONTOESCAL | TABLE | SURICATO | ALTER
TBPROCEAUTOM | TABLE | SURICATO | ALTER
TBREPORT | TABLE | SURICATO | ALTER
TBREPORTCOLUMN | TABLE | SURICATO | ALTER
TBREPORTMAIL | TABLE | SURICATO | ALTER
TBGRUPOEMAILREP | TABLE | SURICATO | ALTER
TBEMAILREP | TABLE | SURICATO | ALTER
TBEMAILREP | TABLE | SURICATO | ALTER
TBAGENDVISIT | TABLE | SURICATO | ALTER
TBUSUAR | TABLE | SURICATO | ALTER
TBVISITLANCAAPROV | TABLE | SURICATO | ALTER
TBHISTOVISITAPROV | TABLE | SURICATO | ALTER
TBMARCAACESS | TABLE | SURICATO | ALTER
TBESVISITWSG | TABLE | SURICATO | ALTER
TBPLAYER | TABLE | SURICATO | ALTER
TBLOGSURICOMAN | TABLE | SURICATO | ALTER
TBLOGSURIDETAL | TABLE | SURICATO | ALTER
TBLOGSURIDETAL | TABLE | SURICATO | ALTER


Release: 2.10.8.1

Tópico:Release: 2.10.8.1

Histórico

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Correções e Melhorias

A seguir uma relação dos itens que entraram nesta versão.

ROTs - Correção

RedMine# | Tipo | Assunto
5346 | ROT | [ROT 267669] - SIKA Relatório de Consumo de Refeitório + Liberação de Faixa Horária
5347 | ROT | [ROT 267687] - SIKA FIVEN Relatório utilizado anteriormente no Suricato 2.9.5 não veio no Suricato 2.10.7
5366 | ROT | [ROT 267887] - SIKA Ao cadastrar Crachá Provisório e procurar o Colaborador é apresentada a Tela Errada de históricos e não apenas com os dados do colaborador, trazendo com isto tela errada com várias linhas e não apenas uma com seus dados
5382 | ROT | [ROT 268946] - FAURECIA Problema ao tentar visualizar quem tem Acesso Restrito cadastrado em um Grupo específico e após conseguirmos pesquisar não traz resultado em EXCEL e PDF


Módulos Alterados

A seguir uma relação de serviços e aplicações que foram criadas ou alterados nesta versão.

Tópico:Módulos Alterados

Aplicações
Banco de Dados

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Aplicações

A seguir uma relação de aplicações criadas ou alterados nesta versão.
APLICAÇÃO | VERSÃO
cnscolabCracha | 1.0.3.2
cnsConsumoRestaurante | 1.0.7.0
cnsConsumoRestauranteResumo | 1.0.7.0
cnsRelatorio | 1.0.5.2
cons_contador_diario | 1.0.7.0
consrestrito | 1.0.5.0
ctrchamaacessorestrito | 1.0.4.0
frmcrachaprovisoriocolaborador | 1.0.13.0
frmTipoRefeicao | 1.0.11.0


Oracle

×

  • Release: 2.10.8.1
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • Oracle
  • Anterior
  • Proxima

Oracle

1. Instruções para execução dos scripts Oracle.
Os scripts de atualização podem ser executados de duas maneiras, somente com o usuário sys ou caso não tenha acesso, pode ser executado com o usuário suricato e telessvr.
Com usuário sys ou privilégios equivalentes
  • •
    Executar apenas o arquivo ORAAtuSys.sql
    Obs.: após executar com o usuário sys, não é necessário executar com os usuários suricato e telessvr.
    Com usuário suricato e telessvr
  • •
    Efetuar logon com usuário telessvr e executar o arquivo ORAAtuTeleSuri.sql
Ele irá pedir o nome registrado no TNSNames (conforme print abaixo), efetuará login com os devidos usuários e irá executar os arquivos:
ORAAtuTeleDDL.sql, ORAAtuTeleDML.sql, ORAAtuSuriDDL.sql, ORAAtuSuriDML.sql, ORAAtuSynoCau.sql e ORAAtuSynoUsu.sql .
Ex.:
Obs.: após executar com os usuários suricato e telessvr, não é necessário executar com o usuário sys.

Tópico:Oracle

Objetos de banco de dados alterados ou criados


Objetos de banco de dados alterados ou criados

×

  • Release: 2.10.8.1
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • Oracle
  • Objetos de banco de dados alterados ou criados
  • Anterior
  • Proxima

Objetos de banco de dados alterados ou criados

Name | Type | Schema | Ação
VTOTALREFEICOESDETALHADO | VIEW | SURICATO | CREATE


SQL Server

×

  • Release: 2.10.8.1
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • SQL Server
  • Anterior
  • Proxima

SQL Server

1. Instruções para execução dos scripts
Os scripts de atualização podem ser executados de duas maneiras, somente com o usuário sa ou caso não tenha acesso, pode ser executado com o usuário suricato e telessvr.
Com usuário sa ou privilégios equivalentes
  • •
    Executar os arquivos:
1 - MSSQL_DDL_ATU_TELE.sql
2 - MSSQL_DDL_ATU_SURI.sql
3 - MSSQL_DML_ATU_SURI.sql
4 - MSSQL_DML_ATU_TELE.sql
5 - PERMISSAOTELE.sql
6 - PERMISSAOSURI.sql
Obs.: após executar com o usuário sa, não é necessário executar com os usuários suricato e telessvr.
Com usuário suricato
  • •
    Efetuar logon com usuário suricato e executar os arquivos:
2 - MSSQL_DDL_ATU_SURI.sql
3 - MSSQL_DML_ATU_SURI.sql
6 - PERMISSAOSURI.sql
Com usuário telessvr
  • •
    Efetuar logon com usuário telessvr e executar o arquivo:
1 - MSSQL_DDL_ATU_TELE.sql
4 - MSSQL_DML_ATU_TELE.sql
5 - PERMISSAOTELE.sql
Obs.: após executar com os usuários suricato e telessvr, não é necessário executar com o usuário sa.

Tópico:SQL Server

Objetos de banco de dados alterados ou criados


Objetos de banco de dados alterados ou criados

×

  • Release: 2.10.8.1
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • SQL Server
  • Objetos de banco de dados alterados ou criados
  • Anterior
  • Proxima

Objetos de banco de dados alterados ou criados

Name | Type | Schema | Ação
VTOTALREFEICOESDETALHADO | VIEW | SURICATO | CREATE


Release: 2.10.8.0

Tópico:Release: 2.10.8.0

Histórico

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Correções e Melhorias

A seguir uma relação dos itens que entraram nesta versão.

ROTs - Correção

RedMine# | Tipo | Assunto
4108 | ROT | [ROT 256021] - Solucionar o problema de planta com número fixo na exportação da CHESF
5226 | ROT | [ROT 264609] - Erro Cadastro das Situações dos Veículos - Problema ocasionado no Oracle pela falta da View SURICATO.VTBTSITUAVEIC

RFPs - Implementação

RedMine# | Tipo | Assunto
4092 | RFP | [RFP 16542] - Implementar os itens faltantes para o concretização do edital de Jacareí
4130 | RFP | [RFP 16591] - Implementar na tela de Cadastro de Saída de Veículos os campos Nota Fiscal e Observação
4182 | RFP | [RFP 16606] - Fase 1 - Integração com a portaria alfandegada LDC
4288 | RFP | [RFP 16612] - WebService REST/JSON para integração de Colaboradores e Afastamento
4308 | RFP | [RFP 16604] - Implementar as tarefas solicitadas pelo cliente BNDES

Melhorias

RedMine# | Tipo | Assunto
4309 | Melhoria | [ScriptCase] - Implementar os dados solicitados na tela de Colabores
4310 | Melhoria | [ScriptCase] - Implementar a regra na tela de Pré Cadastro de Crachás
4311 | Melhoria | [ScriptCase] - Implementar a regra de negócio e campo Via no Cadastro de Visitante
4312 | Melhoria | [ScriptCase] - Implementar na Pesquisa de Colaborador o filtro pelo campo Ramal
4313 | Melhoria | [ScriptCase] - Implementar a escolha da USB no Totem de Captura de Foto
4183 | Melhoria | [ScriptCase] - Criar uma paramatro para definir alfandegado LDC no ParamServi
4184 | Melhoria | [ScriptCase] - Criar no Grupo de Acesso uma opção para definir que é área alfandegada
4185 | Melhoria | [ScriptCase] - Criar na Entrada de Visitante um bloco para definir os dados necessário para a área alfandegada - Regra Parametro + Grupo Alfandegado
4186 | Melhoria | [ScriptCase] - Alterar o Cadastro de Colaborador/Terceiro para disponibilizar os dados necessários para a área alfandegada
4187 | Melhoria | [ScriptCase] - Criar tabela para o tipo de autarquia
4188 | Melhoria | [ScriptCase] - Criar tabela para o tipo de pessoa física
4189 | Melhoria | [ScriptCase] - Criar tela para consulta e reprocessamento do envio de dados alfandegados
4190 | Melhoria | [Middleware] - Implementar o Envio de dados das passagens para a LDC com possibilidade de reprocessamento
5254 | Melhoria | [Matriz Acesso] - Implementar para controle mandatório de refeição setar o StatusAtuCont como zero na tabela CREDACOLAB
4212 | Melhoria | [SuriPlayer] - Implementar a tentativa de recolhimento dos NSR fora de sequencia
4151 | Melhoria | [GerServ] - Implementar o novo comando de reset de supervisão
4152 | Melhoria | [GerServ] - Implementar a geração da lista de supervisão
4167 | Melhoria | [GeradorAplicativo] - Criar um gerador de aplicativo com base na versão 4.26.03 substituindo na aba Validação OffLine de Lista de senha para Lista Supervisor e deixando os campos sempre habilitados
5086 | Melhoria | [Banco] - Alterar a View VHISTORICOCRACHA para incluir os campos HC.ICARD AS CRACHA_LOGICO e HC.ICARD AS CRACHA_FISICO no retorno do SELECT
4724 | Melhoria | [Matriz Acesso] - Implementar para popular as informações necessárias para funcionamento do Relatório Colaborador por Matriz de Acesso
4725 | Melhoria | [Banco] - Revisar os labels do Relatório de Colaborador por Matriz de Acesso, estão todos em Maiusculo
4726 | Melhoria | [ScriptCase] - Implementar um novo Relatório de Colaboradores por Matriz de Acesso
5059 | Melhoria | [ScriptCase] - Implementar funcionalidade que permita o reprocessamento do sincronismo do SuriPlayer
5134 | Melhoria | [Melhoria] - Implementar a definição da Prioridade, Controla Faixa Horária e Crédito Refeitório da Matriz de Acesso
5060 | Melhoria | [ScriptCase] - Implementar a definição da Prioridade, Controla Faixa Horária e Crédito Refeitório da Matriz de Acesso
5135 | Melhoria | [Matriz Acesso] - Implementar a definição da Prioridade, Controla Faixa Horária e Crédito Refeitório da Matriz de Acesso
4723 | Melhoria | [ScriptCase] - Implementar um novo Relatório de Colaboradores por Filial
5277 | Melhoria | [SuriPlayer] - Inclusão REP Henry modelos 61 Hexa, 63 HexaCompacto, 64 PontoE, 65 Primme, 66 PrimmeSF e 67 SuperFacil
4116 | Melhoria | Implementar para apagar o campo PIS quando receber dos ERP´s a carga de um Terceiro
4093 | Melhoria | [ScriptCase] - Trazer RFP implementação do Cadastro de Ocorrencia - TJSC
4094 | Melhoria | [ScriptCase] - Trazer RFP implementação do Securos - UNIMED
4095 | Melhoria | [ScriptCase] - Implementar o Vinculo para exibição da monitoração com a tela de monitoramento do alarme do Securos - Vinculo entre Procedimento e Ocorrencia proveniente do Securos
4096 | Melhoria | [ScriptCase] - Implementar o botão de Procedimento para abertura do PopUp de procedimento de ocorrencia
4097 | Melhoria | [ScriptCase] - Implementar o monitoramento de cameras - Não monitorado, On, Off e Desativado
4101 | Melhoria | Implementar para o SecurOS o recebimento da Velocidade, OCR, Face e laço implementando o acionamento do equipamento pelo comando 60
5126 | Melhoria | [Melhoria] - Substituição do Applet do Java para Cadastro de Biometria Sagem e Suprema
5127 | Melhoria | [ScriptCase] - Implementar na aplicação de Cadastro de Biometria a chamada para o Suricato Client
5140 | Melhoria | [Banco] - Implementar script de atualização do banco de dados a correção da tabela dat08 , dat07 e controle referente a 5 digitos
5229 | Melhoria | Instalação Suricato 2.10.8 - Efetuar a troca da versão para 2.10.8
4176 | Melhoria | [GerServ] - Solucionar o problema do processo de MultiplosCrachas que está fora do processamento de comando
4177 | Melhoria | [GerServ] - Eliminar o processo de Manipula Foto. O processo é executado pelo SuriBank
4179 | Melhoria | [BancoDados] - Criar um novo processo no Suricato na tabela TbProcesOn para os MultiplosGrupos
4701 | Melhoria | [Banco de Dados] - Eliminar as colunas desnecessárias para Oracle e SQLServer na tabela TbMarcaAcess
4712 | Melhoria | Criar regra para envio de comandos quando o equipamento estiver Off Line implementada na versão 2.10.14
5124 | Melhoria | [Suricato Client] - Implementar a captura de biometria para o leitor Suprema
5125 | Melhoria | [Suricato Client] - Implementar a captura de biometria para o leitor Sagem
4285 | Melhoria | [Middleware] - Implementar a restrição de faixa de funcionamento do equipamento utilizando a DAT08. Implementar a mesma regra do CONEX
4409 | Melhoria | [Middleware] - Implementar a restrição de acesso para grupo de acesso restrito
5138 | Melhoria | [Melhoria] - Implementar a funcionalidade para respeitar o parâmetro mandatório de refeição
5136 | Melhoria | [Matriz Acesso] - Implementar a funcionalidade para respeitar o parâmetro mandatório de refeição
5139 | Melhoria | [WS TOTVS] - Implementar a funcionalidade para respeitar o parâmetro mandatório de refeição
5162 | Melhoria | [ScriptCase] - Implementar um novo parâmetro na Configuração Integração TOTVS para definir se irá ignorar totalmente os horários do Suricato
5165 | Melhoria | [Melhoria] - Implementar a funcionalidade para replicação da biometria para o Suriplayer em equipamento de Acesso
5166 | Melhoria | [Banco] - Implementar no banco de dados a replicação da biometria para o Suriplayer em equipamento de Acesso
5167 | Melhoria | [SuriPlayer] - Implementar a replicação da biometria para equipamentos de Acesso

Bugs

RedMine# | Tipo | Assunto
3629 | Bug | ORACLE E MSSQL | Crachás em uso de veículos presentes na consulta
4089 | Bug | Instalação Suricato 2.10.7 - Erro mensagem Access Violation address
4123 | Bug | [ScriptCase] - Solucionar o erro de pesquisar um colaborador com crachá superior a data atual
4282 | Bug | [GerServ] - Solucionar o problema da query dos Multiplos Grupos em Oracle e SQLServer. Está trazendo coluno ambígua
4291 | Bug | [GerServ] - Solucionar o problema de formatação da data na inserção de dados de múltiplos grupos
4303 | Bug | Ao cadastrar um equipamento do Tipo REP diferente dos player externos o campo de local de Prestação não era carregado
4420 | Bug | [Suricato REP] - Solucionar o problema de tentar inserir registros duplicados na tabela suricato.TbAlarSTrata
4421 | Bug | [Suricato REP] - Implementar um tratamento para não exceder o pool de conexões com o banco de dados
5048 | Bug | [GerServ] - Soluciona a falha na importação de Contrato (TBCONTR), Histórico de Afastamento (TBAFAST) e Histórico de Contrato (TBHISTOCONTR)
5072 | Bug | [Banco] - Solucionar o problema na procedure RH_HORESC. Está substituindo o Select no corpo pela falta de tratamento das linhas retornadas
5073 | Bug | [Banco] - Solucionar o problema de processamento da escala na procedure SP_ATUALIZAHORARIO. Atualiza os próximos horários apenas na data de criação
5088 | Bug | MSSQL | Tela Histórico de Afastamento - Erro ao alterar situação trabalhista do afastamento para Demitido
5089 | Bug | ORACLE E MSSQL | sc_btnCrachaYara_top surge após inserir novo colaborador e retorna usuário não autorizado
5107 | Bug | [ScriptCase] - Solucionar o problema na Consulta de Colaboradores por Grupo de REP
5120 | Bug | [ScriptCase] - Solucionar o problema na mensagem de histórico de responsável por veículo
5121 | Bug | [ScriptCase] - Solucionar o problema do Cadastro de Veículos não permitir placas no formato Mercosul
5122 | Bug | [ScriptCase] - Ao realizar busca de crachá com provisório com data futura esta trazendo o crachá já agendado
5141 | Bug | [GerServ] - Implementar para quando não existir o parametro de 5 digitos (VALIDAR5DIGITOSPLANTACODIN ) na definição do PARAM do Suricato adotar como padrão 3 digitos para manter compatibilidade do Suricato
5150 | Bug | [ScriptCase] - Solucionar o problema com inserções de letras no numero do documento do visitante
5155 | Bug | Instalação Suricato 2.10.7 - Problema na tela de bem-vindo no idioma inglês
5179 | Bug | [Banco] - Solucionar o problema da trigger TbMovimCandi_EI. Está faltando na chamada da SP_CANCON o parametro @P_PNE
5182 | Bug | [ScriptCase] - Solucionar o problema com exportação de AFD. Está exportando o indelevel com zero e trazendo registros indevidos em relação ao filtro
5222 | Bug | [GerServ] - ROT 263090_Saint Gobain-Sika_Erro na Importação de Crédito de Refeitório
5223 | Bug | [WS TOTVS] - Solucionar o problema colocar o afastamento de demissão com horário de 00:01. O correto é 23:59
5224 | Bug | [Banco] - Solucionar o problema da View VW_MATRIZ_ACESS_FULL em Oracle. O campo IDLOCALORGAN deve ser CODIORGA.
5231 | Bug | [MSSQL] Erro ao executar sript 2 de atualização
5232 | Bug | [ScriptCase] Tela Sobre ainda apresenta versão 2.10.7
5236 | Bug | [SuriPlayer] - Solucionar o problema do POSIC vazio no insert de marcação na TELESSVR.DAM00
5237 | Bug | ORACLE E MSSQL | Tela Pré-Cadastro de Crachá - Erro de banco
5238 | Bug | MSSQL | Aplicação frmGrupoCamera - Erro de Label
5239 | Bug | ORACLE E MSSQL | Tela Cadastros de Grupos - Sistema permite exclusão de registro vinculado
5240 | Bug | ORACLE E MSSQL | Menus de Grupo de Cameras não têm botão para consulta/filtro
5241 | Bug | ORACLE | Tela Consulta Processamento LDC - Botão pesquisar registros não traz retorno
5242 | Bug | MSSQL | Aplicação cnsProcessamentoLDC - Coluna extra
5243 | Bug | MSSQL | PDF gerado para consulta processamento LDC em modo retrato
5244 | Bug | ORACLE E MSSQL | Tela Relatório de Tipos de Alarme - Botão sair da página duplica menu do Suricato
5248 | Bug | ORACLE E MSSQL | frmGrupoCamera - Congelamento de pop-up
5249 | Bug | ORACLE E MSSQL | frmTipoAlarmesTransito - Congelamento de pop-up
5250 | Bug | [ORACLE] Erro ao executar script de atualização
5251 | Bug | ORACLE | MSSQL - Cadastro de novo Colaborador - Erro campo PIS é preenchido com valor "00.000.000.000"
5252 | Bug | Atualização Suricato 2.10.8 - Manual de descreve ORAAtuSynonym.sql como parte da execução
5255 | Bug | [Oracle e MSSQL] - Não permite associar crachás de veículos com marcas com caractere especial
5259 | Bug | ORACLE E MSSQL | Relatório de Tratamento de Eventos de Trânsito - Erros de botão e string
5260 | Bug | ORACLE E MSSQL | Tela Consulta de Colaboradores por Filial - PDF Gerado corta nome da empresa
5267 | Bug | ORACLE E MSSQL | frmcamercftv - Novo campo adicionado sem label
5269 | Bug | ORACLE E MSSQL | Cadastros de Empregado e Parceiro - Sessão de campos sobre Alfandegado com label Tipo de Terceiro
5271 | Bug | [Banco] - Solucionar o problema na procedure SP_BIOMETRIA de não gerar pendência de sincronismo para equipamentos REP
5276 | Bug | [Oracle] Ao Executar script de atualização foi apresentado erro
5280 | Bug | [ScriptCase] - Solucionar o problema com exportação de AFD. Não está selecionando todos os tipos de equipamento REP
5281 | Bug | [Banco] - Solucionar o problema na PARAMSERVI do parametro HISTORICOCOMPLEMENTARCOLABORADOR ir como padrão S. Esse item deve ser habilitado apenas para o CESERJ
5282 | Bug | [Banco] - Solucionar o problema na PARAMSERVI do parametro HABILITARGRAVACAOCRACHAVIA ir como padrão S. Esse item deve ser habilitado apenas para o CESERJ
5285 | Bug | [Banco] - Solucionar o problema da procedure TBACESSCOLAB_ATUCON. Está formatando os grupos com 5 dígitos
5296 | Bug | ORACLE E MSSQL | ctrConfiguracoesSuri - Campo sem label
5327 | Bug | [Instalação] - Instalação CD Suricato 2.10.7 - Certificado já vem emitido para o IP 172.16.14.248
5339 | Bug | [Banco] - Solucionar o problema da trigger TbMovimCandi_EU e TBENTRACOLAB_EU. Está faltando na chamada da SP_CANCON o parametro @P_PNE
5358 | Bug | [GerServ] - Exportação de AFD está pegando apenas os modelos de equipamento 12 e 17 (CodinREP2000 e CodinREP3000). Alterar para pegar todos os modelos do tipo REP


Conex

A seguir o serviço alterados nesta versão.

Oracle

APLICAÇÃO | VERSÃO
Conex | ConexOxx_38.03.00
Conex REP | ConexRepCrOxx_07.01.00

MSSQL

APLICAÇÃO | VERSÃO
Conex | ConxSql_38.03.01
Conex REP | ConexRepCrSql_07.01.01


Aplicações

A seguir uma relação de aplicações criadas ou alterados nesta versão.
APLICAÇÃO | VERSÃO
frmMatrizAcesso | 1.0.11.0
frmcrachaprovisoriocolaborador | 1.0.13.0
frmprecadastrocracha69cra | 1.0.14.0
ctrConfiguracoesTOTVS | 1.0.17.0
ctrBiometria | 1.0.19.1
ctr_rep_coleta_afd | 1.0.20.0
ctrCapturarFoto | 1.0.20.0
ctrConfiguracoesSuri | 1.0.20.0
consTipoAlarmesTransito | 1.0.3.0
frmCamerasGrupos | 1.0.4.0
cnscolabCracha | 1.0.3.2
consColaboradoresporFilial | 1.0.4.0
consRelatorioAlarmesTransito | 1.0.4.1
ctrEntradaVisitante | 1.0.48.0
cnsProcessamentoLDC | 1.0.5.0
cnsTratamentoEventosTransito | 1.0.5.0
frmGrupoCamera | 1.0.6.0
frmTipoAlarmesTransito | 1.0.6.0
frmveiculocompleto_cad | 1.0.5.0
frmColetores | 1.0.56.2
cons_Cracha_veiculo | 1.0.6.0
consGrupoREP | 1.0.6.0
ctrSobre | 1.0.6.0
frmcamercftv | 1.0.6.0
frmcolaborador | 1.0.67.0
ctrConfiguracoesEntradaVisitantes | 1.0.7.0
frmcargadescargasaida | 1.0.8.0
conscrachavalidos | 1.0.10.0
frmGrupoAcesso | 1.1.6.0
consReprocessamentoPlayerBiometria | 1.0.5.0
cnsCamerasGrupos | 1.0.4.0
cnsGrupoCamera | 1.0.4.0
cnsTipoAlarmesTransito | 1.0.4.0
frmveiculocolaboradores | 1.0.7.1
ctr_monitoramento_camera_transito | N.I
ctr_monitoramento_camera_transito_XML | N.I
ctr_monitoramento_disp_camera | N.I
ctr_monitoramento_disp_camera_JSON | N.I
ctrFotoTransito | N.I
ctrReprocessamentoPlayerBiometria | 1.0.4.0
ctrSelecionaGrupoCameras | N.I


GerServer

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Telemática Gerenciador de Serviços | 2.10.16.5


Suricato REP

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Serviço Suricato REP | v.1.0.4.0


Suricato Middleware

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Serviço Suricato Middleware | V.1.1.12.4


Aplicação de Integração

×

  • Release: 2.10.8.0
  • Histórico
  • Módulos Alterados
  • WebService
  • Aplicação de Integração
  • Anterior
  • Proxima

Aplicação de Integração

APLICAÇÃO | VERSÃO
suricato-totvs.war | suricato-totvs-1.1.3.5.war


SuricatoTotvsMA

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
SURICATO MATRIZ ACESSO | v.1.1.2.1


SuricatoTotvsMarcacao

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Suricato Totvs Marcação | v.1.0.1.0


SuriPlayer

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Suricato Player | v.2.0.8.10


Oracle

×

  • Release: 2.10.8.0
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • Oracle
  • Anterior
  • Proxima

Oracle

1. Instruções para execução dos scripts Oracle.
Os scripts de atualização podem ser executados de duas maneiras, somente com o usuário sys ou caso não tenha acesso, pode ser executado com o usuário suricato e telessvr.
Com usuário sys ou privilégios equivalentes
  • •
    Executar apenas o arquivo ORAAtuSys.sql
    Obs.: após executar com o usuário sys, não é necessário executar com os usuários suricato e telessvr.
    Com usuário suricato e telessvr
  • •
    Efetuar logon com usuário telessvr e executar o arquivo ORAAtuTeleSuri.sql
Ele irá pedir o nome registrado no TNSNames (conforme print abaixo), efetuará login com os devidos usuários e irá executar os arquivos:
ORAAtuTeleDDL.sql, ORAAtuTeleDML.sql, ORAAtuSuriDDL.sql, ORAAtuSuriDML.sql, ORAAtuSynoCau.sql e ORAAtuSynoUsu.sql .
Ex.:
Obs.: após executar com os usuários suricato e telessvr, não é necessário executar com o usuário sys.

Tópico:Oracle

Objetos de banco de dados alterados ou criados


Objetos de banco de dados alterados ou criados

×

  • Release: 2.10.8.0
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • Oracle
  • Objetos de banco de dados alterados ou criados
  • Anterior
  • Proxima

Objetos de banco de dados alterados ou criados

Name | Type | Schema | Ação
TBALARMTRANS_IDX01 | INDEX | SURICATO | CREATE
VW_MATRIZ_ACESS_FULL | FORCEVIEW | SURICATO | CREATE
SP_BIOMETRIA | PROCEDURE | SURICATO | CREATE
SP_SURIPLAYERBIOMETRIA | PROCEDURE | SURICATO | CREATE
SP_ATUALIZAHORARIO | PROCEDURE | SURICATO | CREATE
SP_BIOMETRIA | PROCEDURE | SURICATO | CREATE
TBALARMTRANS_INCLUSAO | TRIGGER | SURICATO | CREATE
TRG_TBALARMTRANS_INSERT | TRIGGER | SURICATO | CREATE
vBuscaColaboradorProvisorio | VIEW | SURICATO | CREATE
VHISTORICOCRACHA | VIEW | SURICATO | CREATE
VHISTORICOCRACHABIOMETRIA | VIEW | SURICATO | CREATE
VTBTSITUAVEIC | VIEW | SURICATO | CREATE
VTBTIPOCOMBU | VIEW | SURICATO | CREATE
SEQ_TBALARMTRANS_IDALARTRAN | SEQUENCE | SURICATO | CREATE
TBAUTARLDC | TABLE | SURICATO | CREATE
TBTEMPLCARGA | TABLE | SURICATO | CREATE
TBTEMPLHISTOCARGA | TABLE | SURICATO | CREATE
TBGRUPOCAMERA | TABLE | SURICATO | CREATE
TBCAMERASGRUPOS | TABLE | SURICATO | CREATE
TBCAMERASGRUPOS | TABLE | SURICATO | CREATE
TBTIPOALARMTRANS | TABLE | SURICATO | CREATE
TBALARMTRANS | TABLE | SURICATO | CREATE
TBFOTOTRANSIT | TABLE | SURICATO | CREATE
TBCARGADESCA | TABLE | SURICATO | ALTER
TBCOMANCODIN | TABLE | SURICATO | ALTER
TBPERMIACESS | TABLE | SURICATO | ALTER
TBESVISIT | TABLE | SURICATO | ALTER
TBCOLAB | TABLE | SURICATO | ALTER
TBFICHACOMPL | TABLE | SURICATO | ALTER
TBCADASCRACH | TABLE | SURICATO | ALTER
TBTIPODOCUM | TABLE | SURICATO | ALTER
TBUSOCRACHBNDES | TABLE | SURICATO | ALTER
TBMATRIZACESS | TABLE | SURICATO | ALTER
TBTEMPLCARGA | TABLE | SURICATO | ALTER
TBGRUPOCAMERA | TABLE | SURICATO | ALTER
TBCAMERASGRUPOS | TABLE | SURICATO | ALTER
TBTIPOALARMTRANS | TABLE | SURICATO | ALTER
TBALARMTRANS | TABLE | SURICATO | ALTER
TBFOTOTRANSIT | TABLE | SURICATO | ALTER
TBCAMERCFTV | TABLE | SURICATO | ALTER
TBACESSCOLAB | TABLE | SURICATO | ALTER
TBCODIN | TABLE | SURICATO | ALTER
TBMARCAACESS | TABLE | SURICATO | ALTER
OFFREPPONTO | TABLE | TELESSVR | CREATE
INDEX1_OFFREPPONTO | INDEX | TELESSVR | CREATE
INDEX2_OFFREPPONTO | INDEX | TELESSVR | CREATE
DIGLOAD002 | TABLE | TELESSVR | CREATE
TRGOFFREPPTO | TRIGGER | TELESSVR | CREATE
SQLCONG3G5_ACE_USUARIO2 | FUNCTION | TELESSVR | CREATE
SQLDIG_REJEIT | FUNCTION | TELESSVR | CREATE
SQLRESP_AUTOPALMV | FUNCTION | TELESSVR | CREATE
SQLFIM_LDIGPALMV | FUNCTION | TELESSVR | CREATE
G3G5_PREP2_PALMV | PROCEDURE | TELESSVR | CREATE
G3G5_PREP2_SAGEM | PROCEDURE | TELESSVR | CREATE
G3G5_PREP2_TSI1 | PROCEDURE | TELESSVR | CREATE
TRATA2_PALMV | PROCEDURE | TELESSVR | CREATE
G3G5_P_GERDIGITAL3 | PROCEDURE | TELESSVR | CREATE
SQLDIG_REJEIT | SYNONYM | USUTCP01 | CREATE
SQLCONG3G5_ACE_USUARIO2 | SYNONYM | USUTCP01 | CREATE
SQLRESP_AUTOPALMV | SYNONYM | USUTCP01 | CREATE
SQLFIM_LDIGPALMV | SYNONYM | USUTCP01 | CREATE
G3G5_PREP2_SAGEM | SYNONYM | CAUSU | CREATE
G3G5_PREP2_TSI1 | SYNONYM | CAUSU | CREATE
G3G5_PREP2_PALMV | SYNONYM | CAUSU | CREATE
TRATA2_PALMV | SYNONYM | CAUSU | CREATE
G3G5_P_GERDIGITAL3 | SYNONYM | CAUSU | CREATE


SQL Server

×

  • Release: 2.10.8.0
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • SQL Server
  • Anterior
  • Proxima

SQL Server

1. Instruções para execução dos scripts
Os scripts de atualização podem ser executados de duas maneiras, somente com o usuário sa ou caso não tenha acesso, pode ser executado com o usuário suricato e telessvr.
Com usuário sa ou privilégios equivalentes
  • •
    Executar os arquivos:
1 - MSSQL_DDL_ATU_TELE.sql
2 - MSSQL_DDL_ATU_SURI.sql
3 - MSSQL_DML_ATU_SURI.sql
4 - MSSQL_DML_ATU_TELE.sql
5 - PERMISSAOTELE.sql
6 - PERMISSAOSURI.sql
Obs.: após executar com o usuário sa, não é necessário executar com os usuários suricato e telessvr.
Com usuário suricato
  • •
    Efetuar logon com usuário suricato e executar os arquivos:
2 - MSSQL_DDL_ATU_SURI.sql
3 - MSSQL_DML_ATU_SURI.sql
6 - PERMISSAOSURI.sql
Com usuário telessvr
  • •
    Efetuar logon com usuário telessvr e executar o arquivo:
1 - MSSQL_DDL_ATU_TELE.sql
4 - MSSQL_DML_ATU_TELE.sql
5 - PERMISSAOTELE.sql
Obs.: após executar com os usuários suricato e telessvr, não é necessário executar com o usuário sa.

Tópico:SQL Server

Objetos de banco de dados alterados ou criados


Objetos de banco de dados alterados ou criados

×

  • Release: 2.10.8.0
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • SQL Server
  • Objetos de banco de dados alterados ou criados
  • Anterior
  • Proxima

Objetos de banco de dados alterados ou criados

Name | Type | Schema | Ação
TBALARMTRANS_INCLUSAO() | FUNCTION | SURICATO | CREATE
TBALARMTRANS_IDX01 | INDEX | SURICATO | CREATE
TBHISTOCRACH_SU | PROCEDURE | SURICATO | CREATE
SP_BIOMETRIA | PROCEDURE | SURICATO | CREATE
SP_SURIPLAYERBIOMETRIA | PROCEDURE | SURICATO | CREATE
RH_HORESC | PROCEDURE | SURICATO | CREATE
SP_ATUALIZAHORARIO | PROCEDURE | SURICATO | CREATE
SP_BIOMETRIA | PROCEDURE | SURICATO | CREATE
TBTIPOPESSOFISICLDC | TABLE | SURICATO | CREATE
TBAUTARLDC | TABLE | SURICATO | CREATE
TBUSOCRACHBNDES | TABLE | SURICATO | CREATE
TBTIPOPESSOFISICLDC | TABLE | SURICATO | CREATE
TBAUTARLDC | TABLE | SURICATO | CREATE
TBTEMPLCARGA | TABLE | SURICATO | CREATE
TBTEMPLHISTOCARGA | TABLE | SURICATO | CREATE
TBGRUPOCAMERA | TABLE | SURICATO | CREATE
TBCAMERASGRUPOS | TABLE | SURICATO | CREATE
TBTIPOALARMTRANS | TABLE | SURICATO | CREATE
TBALARMTRANS | TABLE | SURICATO | CREATE
TBFOTOTRANSIT | TABLE | SURICATO | CREATE
TBMOVIMCANDI_EI | TRIGGER | SURICATO | CREATE
VBUSCACOLABORADORPROVISORIO | VIEW | SURICATO | CREATE
V_COLABORADORESPORFILIAL | VIEW | SURICATO | CREATE
VBUSCACOLABORADORPROVISORIO | VIEW | SURICATO | CREATE
VHISTORICOCRACHA | VIEW | SURICATO | CREATE
VBUSCACOLABORADORPROVISORIO | VIEW | SURICATO | CREATE
VHISTORICOCRACHA | VIEW | SURICATO | CREATE
VHISTORICOCRACHABIOMETRIA | VIEW | SURICATO | CREATE
V_HISTORICO_TRANSITO | VIEW | SURICATO | CREATE
VTBTSITUAVEIC | VIEW | SURICATO | CREATE
VTBTIPOCOMBU | VIEW | SURICATO | CREATE
TBCARGADESCA | TABLE | SURICATO | ALTER
TBMARCAACESS | TABLE | SURICATO | ALTER
TBCOMANCODIN | TABLE | SURICATO | ALTER
TBPERMIACESS | TABLE | SURICATO | ALTER
TBESVISIT | TABLE | SURICATO | ALTER
TBCOLAB | TABLE | SURICATO | ALTER
TBTIPODOCUM | TABLE | SURICATO | ALTER
TBFICHACOMPL | TABLE | SURICATO | ALTER
TBCADASCRACH | TABLE | SURICATO | ALTER
TBUSOCRACHBNDES | TABLE | SURICATO | ALTER
TBMATRIZACESS | TABLE | SURICATO | ALTER
TBTEMPLCARGA | TABLE | SURICATO | ALTER
TBGRUPOCAMERA | TABLE | SURICATO | ALTER
TBCAMERASGRUPOS | TABLE | SURICATO | ALTER
TBTIPOALARMTRANS | TABLE | SURICATO | ALTER
TBALARMTRANS | TABLE | SURICATO | ALTER
TBFOTOTRANSIT | TABLE | SURICATO | ALTER
TBCAMERCFTV | TABLE | SURICATO | ALTER
TBACESSCOLAB | TABLE | SURICATO | ALTER
TBCODIN | TABLE | SURICATO | ALTER
CONTPLANTA_IND1 | INDEX | TELESSVR | CREATE
CONTROLE_IND4 | INDEX | TELESSVR | CREATE
DAT07_IND3 | INDEX | TELESSVR | CREATE
DAT08_IND1 | INDEX | TELESSVR | CREATE
FERIADO_IND1 | INDEX | TELESSVR | CREATE
MATNGRUPOS_IND1 | INDEX | TELESSVR | CREATE
OFFREPPONTO_IND1 | INDEX | TELESSVR | CREATE
OFFREPPONTO_IND2 | INDEX | TELESSVR | CREATE
G3G5_P_GERDIGITAL3 | PROCEDURE | TELESSVR | CREATE
G3G5_PREP2_PALMV | PROCEDURE | TELESSVR | CREATE
G3G5_PREP2_SAGEM | PROCEDURE | TELESSVR | CREATE
G3G5_PREP2_TSI1 | PROCEDURE | TELESSVR | CREATE
REQUEST_LOCK | PROCEDURE | TELESSVR | CREATE
SQLCONG3G5_ACE_USUARIO2 | PROCEDURE | TELESSVR | CREATE
SQLDIG_REJEIT | PROCEDURE | TELESSVR | CREATE
SQLFIM_LDIGPALMV | PROCEDURE | TELESSVR | CREATE
SQLRESP_AUTOPALMV | PROCEDURE | TELESSVR | CREATE
TRATA2_PALMV | PROCEDURE | TELESSVR | CREATE
DIGLOAD002 | TABLE | TELESSVR | CREATE
OFFREPPONTO | TABLE | TELESSVR | CREATE
TRGOFFREPPTOIU | TRIGGER | TELESSVR | CREATE
TRGSITCONT_U | TRIGGER | TELESSVR | CREATE
CONTROLE | TABLE | TELESSVR | ALTER
DAT07 | TABLE | TELESSVR | ALTER
DAT08 | TABLE | TELESSVR | ALTER


Release: 2.10.7.0

Tópico:Release: 2.10.7.0

Histórico

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Correções e Melhorias

A seguir uma relação dos itens que entraram nesta versão.

ROTs - Correção

RedMine # | Tipo | Título
3586 | ROT | [ROT 245041] - Erro ao publicar o relatório no modulo gerador relatório.

RFPs - Implementação

RedMine # | Tipo | Título
3587 | RFP | [RFP 16574] - Criada nova funcionalidade que permite inserir marcações de acesso de forma manual. Esta marcação será identificada no relatório como "Off-Line".
3588 | RFP | [RFP 16588] - Criada nova funcionalidade que permite Integrar o sistema Suricato, com o sistema de CFTV da DIGIFORT.
3597 | RFP | [RFP 16599] - Implementadas melhorias nas configurações necessárias para funcionamento do equipamento TOPDATA.

Melhorias

RedMine # | Tipo | Título
3591 | Melhoria | [Suricato] - Inclusão de Campo de fuso horario na aplicação de Coletores.
3593 | Melhoria | Implementar o controle de refeitório utilizando marcações do REP.
3596 | Melhoria | Inclusão de Botão de Pesquisa no Cadastro de Grupo de REP.
3602 | Melhoria | A aplicação de espelho de Ponto estava com a busca da Situação divergente do Cadastro de Colaboradores para Idiomas.
3603 | Melhoria | Grupo de Acesso Melhorias pra usabilidade de telas.
3616 | Melhoria | Implementação de tratativas de campos para padronização de digitação de 3 e 5 digitos.
3632 | Melhoria | Incluir tipo padrão de situação trabalhista padrão.
3645 | Melhoria | [Middleware] - Implementar controle de afastamento no middleware utilizando informações da controle.
3647 | Melhoria | [SuriPlayer] - Mudança na aquisição do Campo de fuso horario na aplicação de Coletores
4076 | Melhoria | Implementar o recebimento dos dados de Data de Admissão, Foto, Sexo e Data de Nascimento dos ERP´s.
4106 | Melhoria | Implementar a alteração do status de refeitório do credito do colaborador.
4118 | Melhoria | [SuriPlayer] - Implementar uma propriedade no arquivo de configuração que defina o Gateway para pegar os equipamentos para comunicar.
4119 | Melhoria | [SuriPlayer] - Implementar uma propriedade que defina para o equipamento BioPoint o funcionamento da lista.
4121 | Melhoria | [SuriPlayer] - Alterar o comando 54 - Exclusão Total de Empregados - REP para apenas executar o comando de exclusão total de equipamento sem verificar os dados existentes no equipamento.
4122 | Melhoria | [SuriPlayer] - Alterar a rotina que localiza uma pessoa por PIS para trazer apenas um resultado caso a pessoa exista mais de uma vez no banco de dados.
4210 | Melhoria | [SuriPlayer] - Implementar no recebimento do Henry Advanced diferenciar entre a biometria Suprema e Sinatra em relação ao posicionamento do PIS.
4211 | Melhoria | [SuriPlayer] - Implementar no envio de biometria o padrão de conversão do Hexa para o Advanced.
4692 | Melhoria | [SuriPlayer] - Henry Prisma Super Fácil(NÃO INMETRO) implementação de biometria Suprema.
4693 | Melhoria | [SuriPlayer] - Henry Prisma Advanced(INMETRO) implementação de biometria Suprema
4694 | Melhoria | [SuriPlayer] - Para o REP implementar para pegar um novo comando apenas após a finalização do comando corrente.
4695 | Melhoria | [SuriPlayer] - Implementar para o Henry Acesso trabalhar apenas com 1 conexão TCP/IP por equipamento.

Bugs

RedMine # | Tipo | Título
3574 | Bug | Falha Não Permite Afastamento Futuro na Tela.
3590 | Bug | Falha na Liberação de Crédito de Acesso Coletiva - Colaborador/Visitante.
3639 | Bug | [GerServ] - Falha no Processo Automático GerServ com Mensagem NULL NULL.
3641 | Bug | Procedure TbCrachFisic_ATUCON - Falha na inclusão de crachá de número fisico.
3989 | Bug | [SuriPlayer] - Solucionar o problema de continuar a carga de colaboradores e biometrias caso ocorra algum erro com um dos elementos da lista.
3991 | Bug | [Middleware] - Solucionar o problema de NULL na ultima passagem de refeitório. Estava apresentando NULL no campo derrubando a comunicação na consulta de passagem.
3992 | Bug | [Middleware] - Implementar a validação de acesso do controle de refeição parcial.
3993 | Bug | [SuriPlayer] - Solucionar o problema com a formatação de data no recolhimento de registros e conclusão do acesso.
3994 | Bug | [SuriPlayer] - Solucionar o problema com o recolhimento de registros do equipamento Henry.
3995 | Bug | [SuriPlayer] - Solucionar o problema de retirar o Colaborador do REP quando é dado baixa no cartão provisório.
3996 | Bug | Adequação do campo foto - Cadastro de histórico de Crachá e Perfil de acesso.
4066 | Bug | Matriz de Acesso Falha na inclusão de Organogramas no sistema.
4069 | Bug | Captura de Biometria.
4079 | Bug | Apresenta erro no espelho de acesso informando falta de crachá ao realizar um afastamento.
4181 | Bug | [Suricato] - Solucionar o problema na tela de monitoramento de comandos. Não está retornando a informação dos comandos enviados.


Módulos Alterados

A seguir uma relação de serviços e aplicações que foram criadas ou alterados nesta versão.

Tópico:Módulos Alterados

Conex
Aplicações
GerServer
Suricato REP
Suricato Middleware
WebService
SuricatoTotvsMA
SuricatoTotvsMarcacao
SuriPlayer
Banco de Dados
Applet

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Conex

A seguir o serviço alterados nesta versão.

Oracle

APLICAÇÃO | VERSÃO
Conex | ConexOxx_38.02.00
Conex REP | ConexRepCrOxx_07.01.00

MSSQL

APLICAÇÃO | VERSÃO
Conex | ConxSql_38.02.01
Conex REP | ConexRepCrSql_07.01.01


Aplicações

A seguir uma relação de aplicações criadas ou alterados nesta versão.
APLICAÇÃO | VERSÃO
cnsagendamentoautentradaservidor | 1.0.7.0
cnscolab | 1.0.14.0
cnscolabentrada | 1.0.7.0
cnsColetorescad | 1.0.7.0
cnsColetoresPlanta | 1.0.4.0
cnsConsultaPresencaVisitante | 1.0.5.0
cnsConsultaPresencaVisitanteFuncao | 1.0.5.0
cnsConsultaPresencaVisitantes | 1.0.5.0
cnsConsumoRestaurante | 1.0.7.0
cnsConsumoRestauranteResumo | 1.0.7.0
cnsCreditosAcessoColaborador | 1.0.6.1
cnsCreditosAcessoVisitante | 1.0.4.2
cnsGrupoREP | 1.0.5.0
cnsMovimentacaoVisitantes | 1.0.9.0
cnsRefeicoesVisitantes | 1.0.7.0
cnsRelatorio | 1.0.5.2
cnsSaidaVisitantes | 1.0.6.0
cnsSecaoLayout | 1.0.8.0
cnsSituacoes | 1.0.8.1
cnsveiculosmarca_cad | 1.0.3.1
consacessocolaborador | 1.0.20.0
consAcessosRefeitoriosVisitantes | 1.0.5.0
consacessovisitante | 1.0.11.0
consbaixacracha | 1.0.6.0
conscolaboradores | 1.0.15.0
consEditarCodinGrupoAcesso | 1.0.8.0
consentradagrupo | 1.0.6.1
consEntradaVisitantes | 1.0.7.0
consGrupoREP | 1.0.5.0
consHistoricoExternalKeyFilial | 1.0.3.0
consIncluirCodinGrupoAcesso | 1.0.8.0
consMatrizAcesso | 1.0.3.0
consmovimentacaoVisitantes | 1.0.4.0
consoutraempresacad | 1.0.6.0
consQuantidadeVisitas | 1.0.4.0
consRefeicoesVisitantesVisitado | 1.0.5.0
consrelacessovisitante | 1.0.4.0
consrelorganograma | 1.0.7.0
conssaidavisitantes | 1.0.4.0
consultimasvisitas | 1.0.8.0
consVisitantesPresentes | 1.0.4.0
ctrAcessos | 1.0.9.0
ctrautorizacaoacessoimprensa | 1.0.4.0
ctravisocreditos | 1.0.3.0
ctrBiometria | 1.0.18.0
ctrComandos | 1.0.17.1
ctrconfigsenha | 1.0.8.0
ctrConfiguracoesTOTVS | 1.0.16.0
ctrconsumobeneficiosdetalhe | 1.0.4.0
ctrcreditoscoletivos | 1.0.7.2
ctrcreditosdeacessoservidor | 1.0.6.1
ctrcreditosdeacessovisitante | 1.0.4.0
ctrdistribuicaobeneficiocoletiva | 1.0.6.0
ctrEntradaVisitante | 1.0.41.2
ctrEntradaVisitanteComCapFoto | 1.0.7.0
ctrenviodelotes | 1.0.3.0
frmvisitantecorp | 1.0.13.0
frmveiculo | 1.0.6.0
frmusuario | 1.0.10.0
frmsinistros | 1.0.4.0
frmservicftv | 1.0.10.0
frmSenhasAcessoColetores | 1.0.6.0
frmSecaoLayout | 1.0.6.0
frmretiradacoletivabeneficios | 1.0.4.0
frmProcessoAutomatico | 1.0.14.0
frmprecadastrocrachaporfaixa | 1.0.7.0
frmprecadastrocracha69cra | 1.0.12.0
frmprecadastrocracha | 1.0.9.0
frmPlantas | 1.0.11.0
frmoutrasempresas | 1.0.10.0
frmOrganograma | 1.0.8.0
frmnovasenha | 1.0.4.0
frmMatrizAcesso | 1.0.10.0
frmmarcaveiculos | 1.0.6.0
frmlogin | 1.0.9.0
frmLayoutImportacao | 1.0.6.0
frmHistoricoExternalKeyFilial | 1.0.3.1
frmHistoricoContratos | 1.0.10.0
frmhistoricobeneficio | 1.0.5.0
frmHistoricoAfastamento | 1.0.19.0
frmGrupoREP | 1.0.13.0
frmGrupoAcesso | 1.1.6.0
frmfaixarefeitorio | 1.1.4.0
frmfaixaacessovisitante | 1.0.5.5
frmfaixaacessoservidor | 1.0.6.5
frmestruturaorganograma | 1.0.9.0
frmentradavisitante | 1.0.5.0
frmEntradasColetor | 1.0.8.0
frmcrachaprovisoriocolaborador | 1.0.12.0
frmcrachaempregado | 1.0.19.0
frmcorretor | 1.0.4.1
frmColetores | 1.0.56.2
frmcolaboradoresacesso | 1.0.26.0
frmcolaborador | 1.0.65.1
frmCentroCusto | 1.0.10.0
frmcadastroocorrencia | 1.0.9.1
frmcadastroimprensa | 1.0.18.0
frmbaixacracha | 1.0.8.1
frmbaixacoletivahistbeneficios | 1.0.6.0
frmautorizacaoacessoimprensa | 1.0.9.0
frmagendamentoautorizacaoentrada | 1.0.10.0
frmAcessos | 1.0.20.1
frmveiculocolaboradores | N.I
frmveiculofrota | N.I
frm_tbcodinLocalAcess | 1.0.8.0
ctrtrocacracha | 1.0.14.0
ctrSobre | 1.0.6.0
ctrSmartCardActiveXXML | 1.0.6.1
ctrSmartCardActiveX | 1.0.8.1
ctrSenhaAleatoria | 1.0.6.0
ctrselecaocolbaixahistbeneficios | 1.0.4.0
ctrretiradacoletivabeneficios | 1.0.4.0
ctrpronturario | 1.0.4.0
ctrPalm | 1.0.3.0
ctrMarcacaoAcessoManual | 1.0.4.0
ctrImportadorRelatorios | 1.0.4.0
ctrgeraretiradacoletivabeneficios | 1.0.4.0
ctrGeracaoListas | 1.1.4.0
ctrFavoritosRecentes | 1.0.3.2
ctrEspelhoAcesso | 1.0.13.0
ctrdefinicoesfrota | 1.0.3.1
ctr_rep_coleta_afd | 1.0.18.0
ctrPalmCapture | N.I
ctr_monitoramento_comando_XML | 1.0.5.3
ctr_monitoramento_comando | 1.0.5.3
consHistoricoVeiculos | 1.0.4.0
cnsAprovacaoAgendamentoFrota | 1.0.3.1


GerServer

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Telemática Gerenciador de Serviços | 2.10.14.4


Suricato REP

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Serviço Suricato REP | v.1.0.3.16


Suricato Middleware

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Serviço Suricato Middleware | V.1.1.11.10


Aplicação de Integração

×

  • Release: 2.10.7.0
  • Histórico
  • Módulos Alterados
  • WebService
  • Aplicação de Integração
  • Anterior
  • Proxima

Aplicação de Integração

APLICAÇÃO | VERSÃO
suricato-totvs.war | suricato-totvs-1.1.2.4.war


SuricatoTotvsMA

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
SURICATO MATRIZ ACESSO | v.1.1.0.6


SuriPlayer

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Suricato Player | v.2.0.7.12


Oracle

×

  • Release: 2.10.7.0
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • Oracle
  • Anterior
  • Proxima

Oracle

1. Instruções para execução dos scripts Oracle.
Os scripts de atualização podem ser executados de duas maneiras, somente com o usuário sys ou caso não tenha acesso, pode ser executado com o usuário suricato e telessvr.
Com usuário sys ou privilégios equivalentes
  • •
    Executar apenas o arquivo ORAAtuSys.sql
    Obs.: após executar com o usuário sys, não é necessário executar com os usuários suricato e telessvr.
    Com usuário suricato e telessvr
  • •
    Efetuar logon com usuário telessvr e executar o arquivo ORAAtuTeleSuri.sql
Ele irá pedir o nome registrado no TNSNames (conforme print abaixo), efetuará login com os devidos usuários e irá executar os arquivos:
ORAAtuTeleDDL.sql, ORAAtuTeleDML.sql, ORAAtuSuriDDL.sql, ORAAtuSuriDML.sql, ORAAtuSynoCau.sql e ORAAtuSynoUsu.sql .
Ex.:
Obs.: após executar com os usuários suricato e telessvr, não é necessário executar com o usuário sys.

Tópico:Oracle

Objetos de banco de dados alterados ou criados


Objetos de banco de dados alterados ou criados

×

  • Release: 2.10.7.0
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • Oracle
  • Objetos de banco de dados alterados ou criados
  • Anterior
  • Proxima

Objetos de banco de dados alterados ou criados

Name | Type | Schema | Ação
G3G5_P_GERDIGITAL2 | SYNONYM | CAUSU | CREATE
P_RepGerDigital2 | SYNONYM | CAUSU | CREATE
PREP_OUTROSBIOS | SYNONYM | CAUSU | CREATE
sqlfim_rExcAutoDigit2 | SYNONYM | CAUSU | CREATE
sqller_RautoExclDigit2 | SYNONYM | CAUSU | CREATE
sqlratu_outrosbios | SYNONYM | CAUSU | CREATE
sqlrhora_gerbiof | SYNONYM | CAUSU | CREATE
sqlrnivel_biomet | SYNONYM | CAUSU | CREATE
sqlrproc_outrosbios | SYNONYM | CAUSU | CREATE
trata_OutrosBios | SYNONYM | CAUSU | CREATE
trata_RepOutrosBios | SYNONYM | CAUSU | CREATE
trata2_RepTsi1 | SYNONYM | CAUSU | CREATE
trata3_sagem | SYNONYM | CAUSU | CREATE
trata3_tsi1 | SYNONYM | CAUSU | CREATE
TbFichaCompl | TABLE | SURICATO | CREATE
TBLEITOMODEL | TABLE | SURICATO | CREATE
TBTIPORELAT | TABLE | SURICATO | CREATE
AntePrep_ROutrosBios | SYNONYM | SURICATO | ALTER
ANTEPREP2_RSAGEM | SYNONYM | SURICATO | ALTER
AntePrep2_RTsi1 | SYNONYM | SURICATO | ALTER
DATA19001231 | FUNCTION | SURICATO | ALTER
DATAATUAL | FUNCTION | SURICATO | ALTER
GETIDCOLAB | FUNCTION | SURICATO | ALTER
HORAATUAL | FUNCTION | SURICATO | ALTER
Prep_RepDigit2 | SYNONYM | SURICATO | ALTER
SP_BIOMETRIA | PROCEDURE | SURICATO | ALTER
SP_INSCRA | PROCEDURE | SURICATO | ALTER
TBACESSCOLAB | TABLE | SURICATO | ALTER
TBACESSCOLAB_ATUCON | PROCEDURE | SURICATO | ALTER
TBACESSCOLAB_EI | TRIGGER | SURICATO | ALTER
TBACESSCOLAB_EU | TRIGGER | SURICATO | ALTER
TBCAMERCFTV | TABLE | SURICATO | ALTER
TBCODIN | TABLE | SURICATO | ALTER
TBCRACHFISIC_ED | TRIGGER | SURICATO | ALTER
TBCRACHFISIC_EI | TRIGGER | SURICATO | ALTER
TBCRACHFISIC_EU | TRIGGER | SURICATO | ALTER
TBCRACHFISIC_SD | TRIGGER | SURICATO | ALTER
TBCRACHFISIC_SI | TRIGGER | SURICATO | ALTER
TBCRACHFISIC_SU | TRIGGER | SURICATO | ALTER
TBCREDACOLAB | TABLE | SURICATO | ALTER
TBCREDAVISIT | TABLE | SURICATO | ALTER
tbesvisit | TABLE | SURICATO | ALTER
TBHISTOCRACH_SD | TRIGGER | SURICATO | ALTER
TBHISTOCRACH_SU | TRIGGER | SURICATO | ALTER
TBMATRIACESSLORGAN | TABLE | SURICATO | ALTER
TBRELAT | TABLE | SURICATO | ALTER
TBSERVICFTV | TABLE | SURICATO | ALTER
trata2_RepSagem | SYNONYM | SURICATO | ALTER
trg_tbpermingrupos | TRIGGER | SURICATO | ALTER
VHISTORICOCRACHAREP | VIEW | SURICATO | ALTER
VHISTORICOCRACHAREPBIOMETRIA | VIEW | SURICATO | ALTER
VTBDIRECACESS | VIEW | SURICATO | ALTER
VTBSITUAVEICU | VIEW | SURICATO | ALTER
VW_MATRIZ_ACESS_FULL | VIEW | SURICATO | ALTER
AUXMATNREFEIT | TABLE | TELESSVR | CREATE
CONTDIG_OUTROS | TABLE | TELESSVR | CREATE
DIG004 | TABLE | TELESSVR | CREATE
DIG104 | TABLE | TELESSVR | CREATE
HISTDIG | TABLE | TELESSVR | CREATE
MATNREFEIT | TABLE | TELESSVR | CREATE
REPAUTOBIOF | TABLE | TELESSVR | CREATE
AntePrep_ROutrosBios | PROCEDURE | TELESSVR | ALTER
ANTEPREP2_RSAGEM | PROCEDURE | TELESSVR | ALTER
AntePrep2_RTsi1 | PROCEDURE | TELESSVR | ALTER
Auxtrg_digmatcod2 | PROCEDURE | TELESSVR | ALTER
Auxtrg_repDig2 | PROCEDURE | TELESSVR | ALTER
CONTDIG_OUTROS_TBTEMPL | TRIGGER | TELESSVR | ALTER
DIGLOAD001 | TABLE | TELESSVR | ALTER
G3G5_P_GERDIGITAL2 | PROCEDURE | TELESSVR | ALTER
P_RepGerDigital2 | PROCEDURE | TELESSVR | ALTER
PREP_OUTROSBIOS | PROCEDURE | TELESSVR | ALTER
Prep_RepDigit2 | PROCEDURE | TELESSVR | ALTER
REPDIGLOAD001 | TABLE | TELESSVR | ALTER
REPNDIGAUTO000 | TABLE | TELESSVR | ALTER
sqlat_tab_refplanta | FUNCTION | TELESSVR | ALTER
sqlatu_outrosbios_CNX | FUNCTION | TELESSVR | ALTER
sqlBusca_Omok_biomet | FUNCTION | TELESSVR | ALTER
sqlBusca_Outros_biomet | FUNCTION | TELESSVR | ALTER
sqlBusca_Sagem_biomet | FUNCTION | TELESSVR | ALTER
sqlBusca_Tsi1_biomet | FUNCTION | TELESSVR | ALTER
sqlBusca_Veri_biomet | FUNCTION | TELESSVR | ALTER
sqlconG3G5_ace_usuario | FUNCTION | TELESSVR | ALTER
sqlfim_ExcAutoDigit2 | FUNCTION | TELESSVR | ALTER
sqlfim_rExcAutoDigit2 | FUNCTION | TELESSVR | ALTER
sqlhist_bio | FUNCTION | TELESSVR | ALTER
sqller_autoExclDigit2 | FUNCTION | TELESSVR | ALTER
sqller_autoLoadDigit2 | FUNCTION | TELESSVR | ALTER
sqller_RautoExclDigit2 | FUNCTION | TELESSVR | ALTER
sqller_RautoLoadDigit2 | FUNCTION | TELESSVR | ALTER
sqlload_listadig3 | FUNCTION | TELESSVR | ALTER
sqlload_Rlistadig2 | FUNCTION | TELESSVR | ALTER
sqlnivel_geomoksag2 | FUNCTION | TELESSVR | ALTER
sqlratu_outrosbios | FUNCTION | TELESSVR | ALTER
sqlrhora_gerbiof | FUNCTION | TELESSVR | ALTER
sqlrnivel_biomet | FUNCTION | TELESSVR | ALTER
sqlrproc_outrosbios | FUNCTION | TELESSVR | ALTER
sqlver_tipobio | FUNCTION | TELESSVR | ALTER
sqlvermat_nrefeit | FUNCTION | TELESSVR | ALTER
TBTIPOCFTV | TABLE | TELESSVR | ALTER
TMP_NREPDIGATV | TABLE | TELESSVR | ALTER
TMP_NREPDIGGRP | TABLE | TELESSVR | ALTER
TMP_NREPDIGOUTROS | TABLE | TELESSVR | ALTER
TMP_REPVRD001 | TABLE | TELESSVR | ALTER
TMP_REPVRD002 | TABLE | TELESSVR | ALTER
trata_OutrosBios | PROCEDURE | TELESSVR | ALTER
trata_RepOutrosBios | PROCEDURE | TELESSVR | ALTER
trata2_RepSagem | PROCEDURE | TELESSVR | ALTER
trata2_Reptsi1 | PROCEDURE | TELESSVR | ALTER
trata3_sagem | PROCEDURE | TELESSVR | ALTER
trata3_tsi1 | PROCEDURE | TELESSVR | ALTER
trgaltSITGRP | TRIGGER | TELESSVR | ALTER
trgmatcod | TRIGGER | TELESSVR | ALTER
TrgMatNGrupo | TRIGGER | TELESSVR | ALTER
TRGREPFUNC_D | TRIGGER | TELESSVR | ALTER
TRGREPFUNC_IU | TRIGGER | TELESSVR | ALTER
TRGREPGRP_UDI | TRIGGER | TELESSVR | ALTER
sqlat_tab_refplanta | SYNONYM | USUTCP01 | CREATE
sqlatu_outrosbios_CNX | SYNONYM | USUTCP01 | CREATE
sqlBusca_Omok_biomet | SYNONYM | USUTCP01 | CREATE
sqlBusca_Outros_biomet | SYNONYM | USUTCP01 | CREATE
sqlBusca_Sagem_biomet | SYNONYM | USUTCP01 | CREATE
sqlBusca_Tsi1_biomet | SYNONYM | USUTCP01 | CREATE
sqlBusca_Veri_biomet | SYNONYM | USUTCP01 | CREATE
sqlfim_ExcAutoDigit2 | SYNONYM | USUTCP01 | CREATE
sqlhist_bio | SYNONYM | USUTCP01 | CREATE
sqller_autoExclDigit2 | SYNONYM | USUTCP01 | CREATE
sqller_autoLoadDigit2 | SYNONYM | USUTCP01 | CREATE
sqller_RautoLoadDigit2 | SYNONYM | USUTCP01 | CREATE
sqlload_listadig3 | SYNONYM | USUTCP01 | CREATE
sqlload_Rlistadig2 | SYNONYM | USUTCP01 | CREATE
sqlnivel_geomoksag2 | SYNONYM | USUTCP01 | CREATE
sqlver_tipobio | SYNONYM | USUTCP01 | CREATE
sqlvermat_nrefeit | SYNONYM | USUTCP01 | CREATE


SQL Server

×

  • Release: 2.10.7.0
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • SQL Server
  • Anterior
  • Proxima

SQL Server

1. Instruções para execução dos scripts
Os scripts de atualização podem ser executados de duas maneiras, somente com o usuário sa ou caso não tenha acesso, pode ser executado com o usuário suricato e telessvr.
Com usuário sa ou privilégios equivalentes
  • •
    Executar os arquivos:
1 - MSSQL_DDL_ATU_TELE.sql
2 - MSSQL_DDL_ATU_SURI.sql
3 - MSSQL_DML_ATU_SURI.sql
4 - MSSQL_DML_ATU_TELE.sql
5 - PERMISSAOTELE.sql
6 - PERMISSAOSURI.sql
Obs.: após executar com o usuário sa, não é necessário executar com os usuários suricato e telessvr.
Com usuário suricato
  • •
    Efetuar logon com usuário suricato e executar os arquivos:
2 - MSSQL_DDL_ATU_SURI.sql
3 - MSSQL_DML_ATU_SURI.sql
6 - PERMISSAOSURI.sql
Com usuário telessvr
  • •
    Efetuar logon com usuário telessvr e executar o arquivo:
1 - MSSQL_DDL_ATU_TELE.sql
4 - MSSQL_DML_ATU_TELE.sql
5 - PERMISSAOTELE.sql
Obs.: após executar com os usuários suricato e telessvr, não é necessário executar com o usuário sa.

Tópico:SQL Server

Objetos de banco de dados alterados ou criados


Objetos de banco de dados alterados ou criados

×

  • Release: 2.10.7.0
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • SQL Server
  • Objetos de banco de dados alterados ou criados
  • Anterior
  • Proxima

Objetos de banco de dados alterados ou criados

Name | Type | Schema | Ação
AntePrep_ROutrosBios | PROCEDURE | TELESSVR | CREATE
ANTEPREP2_RSAGEM | PROCEDURE | TELESSVR | CREATE
AntePrep2_RTsi1 | PROCEDURE | TELESSVR | CREATE
AUXMATNREFEIT | TABLE | TELESSVR | CREATE
AUXMATNREFEIT_IND1 | UNIQUE INDEX | TELESSVR | CREATE
Auxtrg_repDig2 | PROCEDURE | TELESSVR | CREATE
CONTDIG_OUTROS | TABLE | TELESSVR | CREATE
CONTDIG_OUTROS_IND1 | UNIQUE INDEX | TELESSVR | CREATE
CONTDIG_OUTROS_IND2 | INDEX | TELESSVR | CREATE
CONTDIG_OUTROS_IND3 | INDEX | TELESSVR | CREATE
CONTDIG_OUTROS_TBTEMPL | TRIGGER | TELESSVR | CREATE
CONTPLANTA_IND1 | INDEX | TELESSVR | CREATE
CONTROLE_IND4 | INDEX | TELESSVR | CREATE
DADOSCOLABORADOR | FUNCTION | SURICATO | CREATE
DAM00_EI | TRIGGER | TELESSVR | CREATE
DAT07_IND3 | INDEX | TELESSVR | CREATE
DAT07_IND4 | INDEX | TELESSVR | CREATE
DATA19001231 | FUNCTION | SURICATO | CREATE
DATAATUAL | FUNCTION | SURICATO | CREATE
DIG001_IND5 | INDEX | TELESSVR | CREATE
DIG002_IND2 | INDEX | TELESSVR | CREATE
DIG002_IND3 | INDEX | TELESSVR | CREATE
DIG002_IND4 | INDEX | TELESSVR | CREATE
DIG003_IND5 | INDEX | TELESSVR | CREATE
DIG004 | TABLE | TELESSVR | CREATE
DIG004_IND1 | UNIQUE INDEX | TELESSVR | CREATE
DIG004_IND2 | UNIQUE INDEX | TELESSVR | CREATE
DIG004_IND3 | INDEX | TELESSVR | CREATE
DIG004_IND4 | INDEX | TELESSVR | CREATE
DIG004_IND5 | INDEX | TELESSVR | CREATE
DIG102_IND2 | INDEX | TELESSVR | CREATE
DIG102_IND3 | INDEX | TELESSVR | CREATE
DIG102_IND4 | INDEX | TELESSVR | CREATE
DIG104 | TABLE | TELESSVR | CREATE
DIG104_IND1 | UNIQUE INDEX | TELESSVR | CREATE
DIG104_IND2 | UNIQUE INDEX | TELESSVR | CREATE
DIG104_IND3 | INDEX | TELESSVR | CREATE
DIG104_IND4 | INDEX | TELESSVR | CREATE
DIG104_IND5 | INDEX | TELESSVR | CREATE
G3G5_P_GERDIGITAL2 | PROCEDURE | TELESSVR | CREATE
HISTDIG | TABLE | TELESSVR | CREATE
HORAATUAL | FUNCTION | SURICATO | CREATE
INDEX DAT08_IND1 | UNIQUE | TELESSVR | CREATE
INDEX FERIADO_IND1 | UNIQUE | TELESSVR | CREATE
INDEX MATNGRUPOS_IND1 | UNIQUE | TELESSVR | CREATE
INDEX RDIG004_IND1 | UNIQUE | TELESSVR | CREATE
INDEX RDIG004_IND2 | UNIQUE | TELESSVR | CREATE
INDEX RDIG104_IND1 | UNIQUE | TELESSVR | CREATE
INDEX RDIG104_IND2 | UNIQUE | TELESSVR | CREATE
MATNREFEIT | TABLE | TELESSVR | CREATE
MATNREFEIT_IND1 | UNIQUE INDEX | TELESSVR | CREATE
P_RepGerDigital2 | PROCEDURE | TELESSVR | CREATE
PREP_OUTROSBIOS | PROCEDURE | TELESSVR | CREATE
Prep_RepDigit2 | PROCEDURE | TELESSVR | CREATE
RDIG004_IND4 | INDEX | TELESSVR | CREATE
RDIG004_IND5 | INDEX | TELESSVR | CREATE
RDIG104_IND4 | INDEX | TELESSVR | CREATE
RDIG104_IND5 | INDEX | TELESSVR | CREATE
REPAUTOBIOF | TABLE | TELESSVR | CREATE
REPAUTOBIOF_IND1 | UNIQUE INDEX | TELESSVR | CREATE
REPNDIGAUTO000_IND1A | UNIQUE INDEX | TELESSVR | CREATE
REPNDIGAUTO000_IND3A | UNIQUE INDEX | TELESSVR | CREATE
request_lock | PROCEDURE | TELESSVR | CREATE
SP_BIOMETRIA | PROCEDURE | SURICATO | CREATE
SP_ESCOLTA | PROCEDURE | SURICATO | CREATE
SP_INSCRA | PROCEDURE | SURICATO | CREATE
sp_rastreamento | PROCEDURE | TELESSVR | CREATE
SP_RETCRC | PROCEDURE | SURICATO | CREATE
SP_RETCRC3 | PROCEDURE | SURICATO | CREATE
sqlat_tab_refplanta | PROCEDURE | TELESSVR | CREATE
sqlatG3G5_dados_smartseg | PROCEDURE | TELESSVR | CREATE
sqlatG3G5_tab_acessoSeg | PROCEDURE | TELESSVR | CREATE
sqlatu_outrosbios_CNX | PROCEDURE | TELESSVR | CREATE
sqlatu_veri_CNX | PROCEDURE | TELESSVR | CREATE
sqlatualiza_handkey_tcp | PROCEDURE | TELESSVR | CREATE
sqlatualiza_veri_digital_tcp | PROCEDURE | TELESSVR | CREATE
sqlAtuVagas_Estac | PROCEDURE | TELESSVR | CREATE
sqlbloco_col_dam00_new2 | PROCEDURE | TELESSVR | CREATE
sqlbloco_pend_smart_tcp2 | PROCEDURE | TELESSVR | CREATE
sqlBusca_Omok_biomet | PROCEDURE | TELESSVR | CREATE
sqlBusca_Outros_biomet | PROCEDURE | TELESSVR | CREATE
sqlBusca_Sagem_biomet | PROCEDURE | TELESSVR | CREATE
sqlBusca_Tsi1_biomet | PROCEDURE | TELESSVR | CREATE
sqlBusca_Veri_biomet | PROCEDURE | TELESSVR | CREATE
sqlcon_coacao_omokx | PROCEDURE | TELESSVR | CREATE
sqlcon_coacao_sagemx | PROCEDURE | TELESSVR | CREATE
sqlcon_coacao_tsi1 | PROCEDURE | TELESSVR | CREATE
sqlcon_sagem_digitalit | PROCEDURE | TELESSVR | CREATE
sqlconG3G5_ace_usuario | PROCEDURE | TELESSVR | CREATE
sqlconsG3G5_term_fer_tcp | PROCEDURE | TELESSVR | CREATE
sqlconsG3G5_term_fer_tcp18 | PROCEDURE | TELESSVR | CREATE
sqlconsG3G5_term_tcpoff | PROCEDURE | TELESSVR | CREATE
sqlconsG3G5_term_tcpoff18 | PROCEDURE | TELESSVR | CREATE
sqlfim_ExcAutoDigit2 | PROCEDURE | TELESSVR | CREATE
sqlfim_rExcAutoDigit2 | PROCEDURE | TELESSVR | CREATE
sqlhist_bio | PROCEDURE | TELESSVR | CREATE
sqller_autoExclDigit2 | PROCEDURE | TELESSVR | CREATE
sqller_autoLoadDigit2 | PROCEDURE | TELESSVR | CREATE
sqller_pendon003 | PROCEDURE | TELESSVR | CREATE
sqller_RautoExclDigit2 | PROCEDURE | TELESSVR | CREATE
sqller_RautoLoadDigit2 | PROCEDURE | TELESSVR | CREATE
sqlload_listadig3 | PROCEDURE | TELESSVR | CREATE
sqlload_rlistadig2 | PROCEDURE | TELESSVR | CREATE
sqlnivel_geomoksag2 | PROCEDURE | TELESSVR | CREATE
sqlnivel_sagemit | PROCEDURE | TELESSVR | CREATE
sqlproc_icardpis | PROCEDURE | TELESSVR | CREATE
sqlratu_outrosbios | PROCEDURE | TELESSVR | CREATE
sqlrcon_coacao_omokx | PROCEDURE | TELESSVR | CREATE
sqlrcon_coacao_sagemx | PROCEDURE | TELESSVR | CREATE
sqlrcon_coacao_tsi1 | PROCEDURE | TELESSVR | CREATE
sqlrcon_sagem_digital2 | PROCEDURE | TELESSVR | CREATE
sqlrcon_tsi1_digital2 | PROCEDURE | TELESSVR | CREATE
sqlrgrv_logerros | PROCEDURE | TELESSVR | CREATE
sqlrhora_gerbiof | PROCEDURE | TELESSVR | CREATE
sqlrnivel_biomet | PROCEDURE | TELESSVR | CREATE
sqlrproc_outrosbios | PROCEDURE | TELESSVR | CREATE
sqlver_tipobio | PROCEDURE | TELESSVR | CREATE
sqlvermat_nrefeit | PROCEDURE | TELESSVR | CREATE
TbAcessColab_ATUCON | PROCEDURE | SURICATO | CREATE
TbAcessColab_EI | TRIGGER | SURICATO | CREATE
TbAcessColab_EU | TRIGGER | SURICATO | CREATE
TbCrachFisic_ATUCON | PROCEDURE | SURICATO | CREATE
TBCRACHFISIC_ED | TRIGGER | SURICATO | CREATE
TBCRACHFISIC_EI | TRIGGER | SURICATO | CREATE
TBCRACHFISIC_EU | TRIGGER | SURICATO | CREATE
TBCRACHFISIC_SD | PROCEDURE | SURICATO | CREATE
TBCRACHFISIC_SI | PROCEDURE | SURICATO | CREATE
TBCRACHFISIC_SU | PROCEDURE | SURICATO | CREATE
TbEntraColab_ED | TRIGGER | SURICATO | CREATE
TbEntraColab_EI | TRIGGER | SURICATO | CREATE
TbEntraColab_EU | TRIGGER | SURICATO | CREATE
TBESVISIT_ED | TRIGGER | SURICATO | CREATE
TBESVISIT_EI | TRIGGER | SURICATO | CREATE
TBESVISIT_EU | TRIGGER | SURICATO | CREATE
TbHistGVisit_EI | TRIGGER | SURICATO | CREATE
TbHistGVisit_EU | TRIGGER | SURICATO | CREATE
TBHISTOCRACH_SD | PROCEDURE | SURICATO | CREATE
TBHISTOCRACH_SU | PROCEDURE | SURICATO | CREATE
TBLEITOMODEL | TABLE | SURICATO | CREATE
TbMatriAcessTLOrganIdx01 | UNIQUE NONCLUSTERED INDEX | SURICATO | CREATE
TbMovimCandi_EI | TRIGGER | SURICATO | CREATE
TbMovimCandi_EU | TRIGGER | SURICATO | CREATE
TBTIPOCFTV | TABLE | SURICATO | CREATE
TBTIPORELAT | TABLE | SURICATO | CREATE
TbTrocaPermi_ED | TRIGGER | SURICATO | CREATE
TbTrocaPermi_EI | TRIGGER | SURICATO | CREATE
TbTrocaPermi_EU | TRIGGER | SURICATO | CREATE
TbTrocaPermi_SI | PROCEDURE | SURICATO | CREATE
TbTrocaPermi_SU | PROCEDURE | SURICATO | CREATE
TbVisit_EU | TRIGGER | SURICATO | CREATE
TMP_DIG004 | TABLE | TELESSVR | CREATE
TMP_DIG104 | TABLE | TELESSVR | CREATE
TMP_NREPDIGGRP_IND1 | INDEX | TELESSVR | CREATE
trata_OutrosBios | PROCEDURE | TELESSVR | CREATE
trata_RepOutrosBios | PROCEDURE | TELESSVR | CREATE
trata2_RepSagem | PROCEDURE | TELESSVR | CREATE
trata2_Reptsi1 | PROCEDURE | TELESSVR | CREATE
trata3_sagem | PROCEDURE | TELESSVR | CREATE
trata3_tsi1 | PROCEDURE | TELESSVR | CREATE
trgmatcodD | TRIGGER | TELESSVR | CREATE
trgmatcodI | TRIGGER | TELESSVR | CREATE
trgmatcodU | TRIGGER | TELESSVR | CREATE
TrgMatNGrupo_D | TRIGGER | TELESSVR | CREATE
TrgMatNGrupo_I | TRIGGER | TELESSVR | CREATE
TrgMatNGrupo_U | TRIGGER | TELESSVR | CREATE
TRGREPFUN_D | TRIGGER | TELESSVR | CREATE
TRGREPFUN_I | TRIGGER | TELESSVR | CREATE
TRGREPGRP_D | TRIGGER | TELESSVR | CREATE
TRGREPGRP_I | TRIGGER | TELESSVR | CREATE
TRGREPGRP_U | TRIGGER | TELESSVR | CREATE
TrgSitCont_D | TRIGGER | TELESSVR | CREATE
TrgSitCont_I | TRIGGER | TELESSVR | CREATE
TrgSitCont_U | TRIGGER | TELESSVR | CREATE
VHISTORICOCRACHAREP | VIEW | SURICATO | CREATE
vTbProceOn | VIEW | SURICATO | CREATE
VTBSITUAVEICU | VIEW | SURICATO | CREATE
VW_MATRIZ_ACESS_FULL | VIEW | SURICATO | CREATE
CONTPLANTA | TABLE | TELESSVR | ALTER
CONTROLE | TABLE | TELESSVR | ALTER
DAT07 | TABLE | TELESSVR | ALTER
DAT08 | TABLE | TELESSVR | ALTER
DIGLOAD001 | TABLE | TELESSVR | ALTER
FERIADO | TABLE | TELESSVR | ALTER
MATNGRUPOS | TABLE | TELESSVR | ALTER
REPDIGLOAD001 | TABLE | TELESSVR | ALTER
REPNDIGAUTO000 | TABLE | TELESSVR | ALTER
TbAcesGCodin | TABLE | SURICATO | ALTER
TbAcessCodin | TABLE | SURICATO | ALTER
TBACESSCOLAB | TABLE | SURICATO | ALTER
TbAgendEntra | TABLE | SURICATO | ALTER
TbAgendVisit | TABLE | SURICATO | ALTER
TbAgenGVisit | TABLE | SURICATO | ALTER
TbCadasCrach | TABLE | SURICATO | ALTER
TBCAMERCFTV | TABLE | SURICATO | ALTER
TBCODIN | TABLE | SURICATO | ALTER
TbCodinAcess | TABLE | SURICATO | ALTER
TBCREDACOLAB | TABLE | SURICATO | ALTER
TBCREDAVISIT | TABLE | SURICATO | ALTER
TbDefinAcess | TABLE | SURICATO | ALTER
TbEntraColab | TABLE | SURICATO | ALTER
tbesvisit | TABLE | SURICATO | ALTER
TbFaixaRefei | TABLE | SURICATO | ALTER
TbFichaCompl | TABLE | SURICATO | ALTER
TbGrupoVisit | TABLE | SURICATO | ALTER
TbHistGVisit | TABLE | SURICATO | ALTER
TBMATRIACESSLORGAN | TABLE | SURICATO | ALTER
TbMotiACandi | TABLE | SURICATO | ALTER
TbMovimCandi | TABLE | SURICATO | ALTER
TbPermAColab | TABLE | SURICATO | ALTER
TbPermAVisit | TABLE | SURICATO | ALTER
TbPermGCodin | TABLE | SURICATO | ALTER
TbPermiAcess | TABLE | SURICATO | ALTER
TbProceOn | TABLE | SURICATO | ALTER
TBRELAT | TABLE | SURICATO | ALTER
TBSERVICFTV | TABLE | SURICATO | ALTER
TBTIPOCFTV | TABLE | SURICATO | ALTER
TBTIPORELAT | TABLE | SURICATO | ALTER
TbTipoVisit | TABLE | SURICATO | ALTER
TbTrocaPermi | TABLE | SURICATO | ALTER
TbVisit | TABLE | SURICATO | ALTER
TMP_NREPDIGATV | TABLE | TELESSVR | ALTER
TMP_NREPDIGGRP | TABLE | TELESSVR | ALTER
TMP_NREPDIGOUTROS | TABLE | TELESSVR | ALTER
TMP_REPVRD001 | TABLE | TELESSVR | ALTER
TMP_TD | TABLE | TELESSVR | ALTER


Applet

A seguir os serviços alterados nesta versão.
Aplicação | Versão
monitor.jnlp | N/A
monitor-oracle.jnlp | N/A
suricato-monitoramento.jar | 1.5.4.0
suricato-monitoramento-dll.jar | 1.5.4.0
suricato-monitoramento-libs.jar | 1.5.4.0
applet Suprema Biometric | 1.1.3.3
applet Sagem | 1.0.3.0


Release: 2.10.6.1

Tópico:Release: 2.10.6.1

Histórico

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Correções e Melhorias

A seguir uma relação dos itens que entraram nesta versão.

ROTs - Correção

RedMine # | Tipo | Título
3084 | ROT | [ROT 16537.1] - Goodyear - Administração de Benefícios
3100 | ROT | [ROT - 243047] - Marinha do Brasil - Crachá multi-tecnologia Provisório - ao passar provisório físico apresenta a mensagem matricula não cadastrada.
3133 | ROT | [ROT 244390] - Horário da próxima execução e da última execução estão aparecendo invertido.
3153 | ROT | [ROT 244296] -PROVISÓRIO AFASTADO - REFERENTE A ROT 236022 - #2685
3154 | ROT | [ROT 245383] - YARA - DUPLICA DOCUMENTO VISITANTE AO INSERIR NOVO VISITANTE.

RFPs - Implementação

RedMine # | Tipo | Título
16551 | RFP | [RFP 16551] - Adequação do Controle de Usuários e Senha para o Banco Volkswagem.

Melhorias

RedMine # | Tipo | Título
3143 | Melhoria | Implementar o equipamento TOPDATA Acesso com biometria NITGEN.
3223 | Melhoria | Inclusão de tratamento para envio de comandos para outros players com padronização REP Inmetro.
3144 | Melhoria | Implementar o equipamento TOPDATA REP com biometria LC.
3130 | Melhoria | Implementar o modelo de Equipamento para Henry e também a biometria Sinatra.
3131 | Melhoria | Implementar o equipamento HENRY - HexaAdvanced com a biometria Sinatra.
2158 | Melhoria | Processo automático - SuriPlayer.
3295 | Melhoria | Melhoria para o Tratamento de exibição da external key para Tela de coletores.
3173 | Melhoria | TOTVS - Implementar WebService para CODIN, REP e Grupo de Acesso - Cliente Azul.
3105 | Melhoria | Inclusão de Filial, Coletores e external Key para Equipamentos Refeitório.
3135 | Melhoria | Criar o controle de refeições - Mandatório.
3273 | Melhoria | Na instalação permitir que o usuário possa escolher o path da instalação.
2779 | Melhoria | Identificação | Colaborador | Matriz de acesso - não possui botão buscar.
3047 | Melhoria | Cadastro de ocorrências - Carregar o Local.
3080 | Melhoria | Geração De listas apresenta erro de mensagens.
3079 | Melhoria | Alterar a views de de Histórico de Crachá Rep e Biometria.
3125 | Melhoria | Implementar Entrada de Visitante para Manter o Histórico da Empresa do Visitante.

Bugs

RediMine # | Tipo | Título
2149 | Bug | Sistema não atualiza biometrias já existentes em novos codins adicionados.
3160 | Bug | Replicar Biometria entre os Schemas SURICATO e TELESSVR.
3164 | Bug | Erro no resumo do relatório de consumo de refeitório.
3317 | Bug | Consulta de Pesquisa de colaboradores Não estava tratando corretamente.
3141 | Bug | Solucionar o problema das variáveis em SQLSERVER quando o banco de dados Master do Cliente for GENERALBIN. Ainda obriga o banco de dados do Suricato ser LATIN1_GENERAL_CI_AS.
3194 | Bug | Ao executar o Gerserv esta gerando um erro de objeto sql não encontrado.
3108 | Bug | Duplicidade de Tela ao Clicar na Imagem de Página Não Encontrada.
3111 | Bug | Duplicidade no Retorno da View VHISTORICOCRACHAREP no Cenário de Histórico de Número Físico.
3109 | Bug | Trocar Label de Comando REP de "Digitais Especial" para "Exclusão Total de Empregado"
3110 | Bug | Não Processar SP_REP e Afins Quando Utilizar o Software SURICATO-REP.
3145 | Bug | Solucionar o problema na SP_VISCON. Está colocando fixo o código de controle de biometria.
3106 | Bug | Falha na Opção de "Não utiliza biometria" no REP.
3193 | Bug | [Conex] - Solucionar o problema no envio do nível de sensibilidade do sensor biométrico. Está sempre enviando 1 ao invés do valor configurado.
3107 | Bug | Ocorrendo Erro de Duplicidade de PIS no Ambiente TOTVS.
3316 | Bug | Permissão de Acesso de Cadastro de Veículos.
3091 | Bug | Incluir tipo de modelo de equipamento Henry Acesso não Inmetro.
3318 | Bug | Melhorias TOTVS - WebServices e Integração (Nascimento, Sexo, Foto, Remoção do PIS, Situação de Afastamento).


Módulos Alterados

A seguir uma relação de serviços e aplicações que foram criadas ou alterados nesta versão.

Tópico:Módulos Alterados

WebService
GerServer
Aplicações
Banco de Dados
SuricatoTotvsMA
Suricato REP
Suricato Middleware

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Aplicação de Integração

×

  • Release: 2.10.6.1
  • Histórico
  • Módulos Alterados
  • WebService
  • Aplicação de Integração
  • Anterior
  • Proxima

Aplicação de Integração

APLICAÇÃO | VERSÃO
suricato-totvs.war | suricato-totvs-1.1.2.3.war


GerServer

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Telemática Gerenciador de Serviços | 2.10.12.0


Aplicações

A seguir uma relação de aplicações criadas ou alterados nesta versão.
APLICAÇÃO | VERSÃO
frmusuario | 1.0.10.0
frmoutrasempresas | 1.0.10.0
frmMatrizAcesso | 1.0.10.0
frmGrupoAcesso | 1.0.10.0
frmfaixarefeitorio | 1.0.10.0
frmagendamentoautorizacaoentrada | 1.0.10.0
consacessovisitante | 1.0.10.0
frmprecadastrocracha69cra | 1.0.11.0
frmGrupoREP | 1.0.11.0
frmcrachaprovisoriocolaborador | 1.0.12.0
frmProcessoAutomatico | 1.0.14.0
ctrtrocacracha | 1.0.14.0
ctrConfiguracoesTOTVS | 1.0.15.0
conscolaboradores | 1.0.15.0
ctrComandos | 1.0.17.1
frmcadastroimprensa | 1.0.18.0
ctr_rep_coleta_afd | 1.0.18.0
consacessocolaborador | 1.0.18.0
frmAcessos | 1.0.20.1
ctrenviodelotes | 1.0.3.0
consMatrizAcesso | 1.0.3.0
consHistoricoExternalKeyFilial | 1.0.3.0
frmHistoricoExternalKeyFilial | 1.0.3.1
cnsAprovacaoAgendamentoFrota | 1.0.3.1
frmestruturaorganograma | 1.0.3.2
ctrFavoritosRecentes | 1.0.3.2
frmretiradacoletivabeneficios | 1.0.4.0
frmnovasenha | 1.0.4.0
frmcadastroocorrencia | 1.0.4.0
ctrselecaocolbaixahistbeneficios | 1.0.4.0
ctrretiradacoletivabeneficios | 1.0.4.0
ctrpronturario | 1.0.4.0
ctrgeraretiradacoletivabeneficios | 1.0.4.0
ctrconsumobeneficiosdetalhe | 1.0.4.0
ctrautorizacaoacessoimprensa | 1.0.4.0
conssaidavisitantes | 1.0.4.0
consrelacessovisitante | 1.0.4.0
cnsColetoresPlanta | 1.0.4.0
frmcorretor | 1.0.4.1
ctrEntradaVisitante | 1.0.40.1
frmveiculocolaboradores | 1.0.5.0
frmhistoricobeneficio | 1.0.5.0
consGrupoREP | 1.0.5.0
cnsConsultaPresencaVisitante | 1.0.5.0
frmColetores | 1.0.56.0
frmSenhasAcessoColetores | 1.0.6.0
frmSecaoLayout | 1.0.6.0
frmLayoutImportacao | 1.0.6.0
frmbaixacoletivahistbeneficios | 1.0.6.0
ctrSobre | 1.0.6.0
ctrdistribuicaobeneficiocoletiva | 1.0.6.0
consoutraempresacad | 1.0.6.0
cnsSaidaVisitantes | 1.0.6.0
consentradagrupo | 1.0.6.1
frmcolaborador | 1.0.63.0
ctrEntradaVisitanteComCapFoto | 1.0.7.0
consultimasvisitas | 1.0.7.0
consEntradaVisitantes | 1.0.7.0
cnsConsumoRestauranteResumo | 1.0.7.0
cnsConsumoRestaurante | 1.0.7.0
frm_tbcodinLocalAcess | 1.0.8.0
ctrconfigsenha | 1.0.8.0
cnsSecaoLayout | 1.0.8.0
ctrSmartCardActiveX | 1.0.8.1
cnsSituacoes | 1.0.8.1
frmprecadastrocracha | 1.0.9.0
frmlogin | 1.0.9.0
frmautorizacaoacessoimprensa | 1.0.9.0
ctrAcessos | 1.0.9.0
cnsMovimentacaoVisitantes | 1.0.9.0
ctrGeracaoListas | 1.1.3.0
ctrSmartCardActiveXXML | 1.0.6.1
ctrPalmCapture | N.I
ctrPalm | N.I
cnscolabentrada | 1.0.7.0


Oracle

×

  • Release: 2.10.6.1
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • Oracle
  • Anterior
  • Proxima

Oracle

1. Instruções para execução dos scripts Oracle.
Os scripts de atualização podem ser executados de duas maneiras, somente com o usuário sys ou caso não tenha acesso, pode ser executado com o usuário suricato e telessvr.
Com usuário sys ou privilégios equivalentes
  • •
    Executar apenas o arquivo AtuSys2105to2106.sql
    Obs.: após executar com o usuário sys, não é necessário executar com os usuários suricato e telessvr.
    Com usuário suricato e telessvr
  • •
    Efetuar logon com usuário suricato e executar o arquivo AtuTeleSuri2105to2106.sql que executará os arquivos AtuSuriDDL2105to2106.sql e AtuSuriDML_2105_2106.sql, e irá solicitar o tns de conexão para o usuário telessvr, conforme figura abaixo, que executará os arquivos AtuTeleDDL2105to2106.sql e AtuTeleDML_2105to2106.sql
    Ex.:
Obs.: após executar com os usuários suricato e telessvr, não é necessário executar com o usuário sys.

Tópico:Oracle

Objetos de banco de dados alterados ou criados


Objetos de banco de dados alterados ou criados

×

  • Release: 2.10.6.1
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • Oracle
  • Objetos de banco de dados alterados ou criados
  • Anterior
  • Proxima

Objetos de banco de dados alterados ou criados

Name | Type | Schema | Ação
VEPISVENCIMENTO | VIEW | SURICATO | Criação
VHISTORICOCRACHA | VIEW | SURICATO | Alteração
VHISTORICOCRACHAACESSO | VIEW | SURICATO | Alteração
VHISTORICOCRACHABIOMETRIA | VIEW | SURICATO | Criação
VHISTORICOCRACHADEMITIDO | VIEW | SURICATO | Alteração
VHISTORICOCRACHAREP | VIEW | SURICATO | Criação
VHISTORICOCRACHASENHA | VIEW | SURICATO | Criação
VTBCODINLISTA | VIEW | SURICATO | Alteração
VTBPERMIACESS | VIEW | SURICATO | Alteração
VTBPROCEON | VIEW | SURICATO | Alteração
V_ACESSOREFEIVISI | VIEW | SURICATO | Alteração
VEPISVENCIMENTO | VIEW | SURICATO | Criação
V_REFEICAOVISITANTE | VIEW | SURICATO | Criação
VW_MARCACAO_TOTVS | VIEW | SURICATO | Alteração
TRG_TBHISTOEPICOLAB_INSERT | TRIGGER | SURICATO | Criação
TBPROCEON | TABLE | SURICATO | Criação de campo
TBLOCALCOLET | TABLE | SURICATO | Criação de campo
TBTIPOLEITO | TABLE | SURICATO | Criação de campo
TBESVISIT | TABLE | SURICATO | Criação de campo e constraint
TBFAIXAREFEI | TABLE | SURICATO | Criação de campos
TBHISTOFILIACODIN | TABLE | SURICATO | Nova
TBHISTOSENHAUSUAR | TABLE | SURICATO | Nova
TBLEITOMODEL | TABLE | SURICATO | Nova
TBUSERSHIFTWORKFUTURO | TABLE | SURICATO | Nova
TBHISTOEPICOLAB | TABLE | SURICATO | Criação
TBVERSOES | TABLE | SURICATO | Nova
TBMODELCONTR | TABLE | SURICATO | Alteração
TBCODIN | TABLE | SURICATO | Alteração
SEQ_TBHISTOEPICOLAB_ID | SEQUENCE | SURICATO | Criação
SP_BIOMETRIA | PROCEDURE | SURICATO | Alteração
SP_REP | PROCEDURE | SURICATO | Alteração
SP_CRACON | PROCEDURE | SURICATO | Alteração
SP_REPDELETE | PROCEDURE | SURICATO | Alteração
SP_REPNUMEROFISICO | PROCEDURE | SURICATO | Alteração
SP_REPTROCA | PROCEDURE | SURICATO | Alteração
SP_VISCON | PROCEDURE | SURICATO | Alteração
DATA19001231 | FUNCTION | SURICATO | Criação
DATAATUAL | FUNCTION | SURICATO | Criação
HORAATUAL | FUNCTION | SURICATO | Criação
INSTRCHAVEXT | FUNCTION | SURICATO | Criação
CONTDIG_SAGEM_TBTEMPL | TRIGGER | TELESSVR | Alteração
CONTDIG_TSI1_TBTEMPL | TRIGGER | TELESSVR | Criação
CONTROLE_BIOMETRIA_REP | TRIGGER | TELESSVR | Criação
PALMV001_TBTEMPL | TRIGGER | TELESSVR | Criação
SITENTRADA_EI | TRIGGER | TELESSVR | Criação
TRG_INSERT_TBBIOAUTOM_OP4 | TRIGGER | TELESSVR | Criação
TRG_INSERT_TBBIOAUTOM_SAGEM | TRIGGER | TELESSVR | Criação
VERSOES | TABLE | TELESSVR | Criação
REPEMPR002SINC | TABLE | TELESSVR | Criação
SQLCONG3G5_ACE_USUARIO | FUNCTION | TELESSVR | Alteração
SQLRNIVEL_BIOMET | FUNCTION | TELESSVR | Alteração


SQL Server

×

  • Release: 2.10.6.1
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • SQL Server
  • Anterior
  • Proxima

SQL Server

1. Instruções para execução dos scripts
Os scripts de atualização podem ser executados de duas maneiras, somente com o usuário sa ou caso não tenha acesso, pode ser executado com o usuário suricato e telessvr.
Com usuário sa ou privilégios equivalentes
  • •
    Executar os arquivos:
1 - MSSQL_DDL_ATUALIZACAO.SQL.sql,
2 - MSSQL_DML.SQL
3 - PERMISSAOSURI.SQL
4 - PERMISSAOTELE.SQL
Obs.: após executar com o usuário sa, não é necessário executar com os usuários suricato e telessvr.
Com usuário suricato
  • •
    Efetuar logon com usuário suricato e executar os arquivos:
1 - MSSQL_DDL_ATUALIZACAO.SQL.sql,
2 - MSSQL_DML.SQL
3 - PERMISSAOSURI.SQL
Com usuário telessvr
  • •
    Efetuar logon com usuário telessvr e executar o arquivo:
4 - PERMISSAOTELE.SQL
Obs.: após executar com os usuários suricato e telessvr, não é necessário executar com o usuário sa.

Tópico:SQL Server

Objetos de banco de dados alterados ou criados


Objetos de banco de dados alterados ou criados

×

  • Release: 2.10.6.1
  • Histórico
  • Módulos Alterados
  • Banco de Dados
  • SQL Server
  • Objetos de banco de dados alterados ou criados
  • Anterior
  • Proxima

Objetos de banco de dados alterados ou criados

Name | Type | Schema | Ação
TBFAIXAREFEI | TABLE | SURICATO | Criação de campo
TBLOCALCOLET | TABLE | SURICATO | Criação de campo
TBPROCEON | TABLE | SURICATO | Criação de campo
TBTIPOLEITO | TABLE | SURICATO | Criação de campo
TBHISTOFILIACODIN | TABLE | SURICATO | Criação
TBLEITOMODEL | TABLE | SURICATO | Criação
TBUSERSHIFTWORKFUTURO | TABLE | SURICATO | Criação
VHISTORICOCRACHAREP_GRUPOREPCODIN | VIEW | SURICATO | Criação
VHISTORICOCRACHA | VIEW | SURICATO | Criação
VHISTORICOCRACHAACESSO | VIEW | SURICATO | Criação
VHISTORICOCRACHABIOMETRIA | VIEW | SURICATO | Criação
VHISTORICOCRACHADEMITIDO | VIEW | SURICATO | Criação
VHISTORICOCRACHAREP | VIEW | SURICATO | Criação
VHISTORICOCRACHASENHA | VIEW | SURICATO | Criação
VTBCODINLISTA | VIEW | SURICATO | Criação
VTBPROCEON | VIEW | SURICATO | Alteração
V_REFEICAOVISITANTE | VIEW | SURICATO | Criação
SP_BIOMETRIA | PROCEDURE | SURICATO | Criação
SP_CRACON | PROCEDURE | SURICATO | Alteração
SQLCONG3G5_ACE_USUARIO | FUNCTION | TELESSVR | Criação
SQLATG3G5_TAB_ACESSOSEG | FUNCTION | TELESSVR | Criação
CONTDIG_SAGEM_TBTEMPL | TRIGGER | TELESSVR | Criação
TBALARSTRATA_INCLUSAO | FUNCTION | SURICATO | Criação
CONTDIG_TSI1_TBTEMPL | TRIGGER | TELESSVR | Criação
SQLCONSG3G5_TERM_FER_TCP | FUNCTION | TELESSVR | Criação
CONTROLE_BIOMETRIA_REP | TRIGGER | TELESSVR | Criação
PALMV001_TBTEMPL | TRIGGER | TELESSVR | Criação
TBTEMPL_BIOMETRIA | TRIGGER | SURICATO | Criação
SITENTRADA_EI | TRIGGER | TELESSVR | Alteração
SQLRNIVEL_BIOMET | FUNCTION | TELESSVR | Alteração
TBHISTOEPICOLAB | TABLE | SURICATO | Criação
VEPISVENCIMENTO | VIEW | SURICATO | Criação
TBHISTOSENHAUSUAR | TABLE | SURICATO | Criação
VEPISVENCIMENTO | VIEW | SURICATO | Criação
INSTR | FUNCTION | SURICATO | Criação


SuricatoTotvsMA

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
SURICATO MATRIZ ACESSO | v.1.1.0.3


Suricato Middleware

A seguir o serviço alterados nesta versão.
APLICAÇÃO | VERSÃO
Serviço Suricato Middleware | V.1.0.7.1