Título

×

  • Título
  • Proxima
Instruções para Atualização Suricato
Execute atentamente os passos a seguir para atualizar o sistema Suricato com sucesso!
Guia do Usuário
2020

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.

® Marcas Registradas
SURICATO, e CODIN, são marcas registradas da Telemática sistemas Inteligentes. Especificações técnicas e suas disponibilidades estão sujeitas a alterações sem aviso prévio.


Leia-me Primeiro

  • 1.
    Sobre o UpdateSuricato2.10.x.x.exe.
  • 1.1.
    O executável "UpdateSuricato2.10.x.x.exe", é um pacote de atualização do Suricato, compatível com as versões 2.10 do Suricato, desenvolvido pela Telemática Sistemas Inteligentes, com a finalidade de agilizar o processo de atualização do Suricato.
  • 2.
    Como Funciona?
  • 2.1.
    Obrigatoriamente o UpdateSuricato2.10.x.x.exe, deverá ser executado dentro da pasta raiz do Suricato.
  • 2.2.
    Uma vez executado, o atualizador irá substituir a aplicação atual do Suricato, pela versão compilada no referido atualizador.
  • 3.
    Precauções.
  • 3.1.
    Realizar backup da aplicação Suricato.
  • 3.2.
    Realizar a atualização do sistema de forma fácil e segura, seguindo os passos a seguir.

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.

® Marcas Registradas


1o. Passo

Descreveremos a seguir os primeiros passos para atualização do Suricato, a partir da versão: 2.10.5.5.

Tópico:1o. Passo

Primeiro Passo - Parar os Serviços

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Primeiro Passo - Parar os Serviços

Parar os serviços da aplicação Suricato, conforme a sequência, dos tópicos abaixo.
Primeiro Passo - Parar os Serviços

Telemática Suricato - Apache

1. Telemática Suricato - Apache
Localize o serviço "Telemática Suricato", conforme a imagem, e "Pare" o serviço.
Topo

Telemática Gerenciador Serviços - Gerserv

2. Telemática Gerenciador Serviços - Gerserv
Localize o serviço "Telemática_Gerenciador_Servicos", conforme a imagem, e "Pare" o serviço.
Topo

Suricato REP

3. Suricato REP
Localize o serviço "Suricato REP", conforme a imagem, e "Pare" o serviço.
Topo

Suricato Player

4. Suricato Player
Localize o serviço "Suricato Player", conforme a imagem, e "Pare" o serviço.
Topo

Suricato Middleware

5. Suricato Middleware
Localize o serviço "Suricato Middleware", conforme a imagem, e "Pare" o serviço.
Topo

Suricato Matriz de Acesso

6. Suricato Matriz de Acesso
Localize o serviço "Suricato Matriz de Acesso", conforme a imagem, e "Pare" o serviço.
Topo

Conexão Codin Telemática

7. Conexão Codin Telemática
Localize o serviço "Conexão Codin Tlemática", e "Pare" o serviço.
Topo

Conexão CodinReP Telemática

8. Conexão CodinReP Telemática
Localize o serviço "Conexão CodinReP Telemática", e "Pare" o serviço.
Topo

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


2o. Passo

Descreveremos a seguir os próximos passos para atualização do Suricato, a partir da versão: 2.10.5.5.

Tópico:2o. Passo

Segundo Passo - Backup da Pasta Raiz

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Segundo Passo - Backup da Pasta Raiz

Realizar o backup da aplicação Suricato, conforme a sequência, dos tópicos abaixo.
Segundo Passo - Backup da Pasta Raiz

Pasta Suricato

1. Pasta Suricato
Realize uma cópia da pasta raiz do Suricato.
Topo

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


3o. Passo

Descreveremos a seguir os próximos passos para atualização do Suricato, a partir da versão: 2.10.5.5.

Tópico:3o. Passo

Terceiro Passo - Copiar e Executar Atualizador


Terceiro Passo - Copiar e Executar Atualizador

Copiar e executar o atualizador "UpdateSuricato2.10.xx.exe", conforme a sequência, dos tópicos abaixo.
Terceiro Passo - Copiar e Executar Atualizador

Atualizador Suricato

1. Atualizador Suricato
Copie o arquivo "Atualizador do Suricato" para a pasta Raiz do Suricato, conforme a imagem. É necessário executar com permissões de Administrador.
Topo

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


4o. Passo

Descreveremos a seguir os próximos passos para atualização do Suricato, a partir da versão: 2.10.5.5.

Tópico:4o. Passo

Quarto Passo - Atualizar Banco de Dados

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Quarto Passo - Atualizar Banco de Dados

Atualizar o banco de dados da aplicação Suricato, conforme a sequência, dos tópicos abaixo.
Quarto Passo - Atualizar Banco de Dados

Atualização do Banco de Dados - Oracle

1. Atualização do Banco de Dados - Oracle
Localize dentro da pasta "oracle" os scripts de atualização do banco. Execute os script conforme instruções .
Topo

Atualização do Banco de Dados - SQL Server

2. Atualização do Banco de Dados - SQL Server
Localize dentro da pasta "sql" os scripts de atualização do banco. Execute os scripts conforme instruções .
Topo

Tópico:Quarto Passo - Atualizar Banco de Dados

Atualizar Banco de Dados - Oracle
Atualizar Banco de Dados - SqlServer

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Atualizar Banco de Dados - Oracle

Instruções para execução dos scripts Oracle:
  • 1.
    Os scripts de atualização podem ser executados de duas maneiras:
  • 1.1.
    Somente com o usuário sys ou, caso não tenha acesso, pode ser executado com o usuário suricato e telessvr.
  • 1.2.
    Com usuário sys ou privilégios equivalentes:
  • 1.3.
    Obs.: após executar com o usuário sys, não é necessário executar com os usuários suricato e telessvr.
  • 1.4.
    Executar apenas o arquivo ORAAtuSys.sql
  • 2.
    Com usuário suricato e telessvr:
  • 2.1.
    Efetuar logon com usuário telessvr e executar o arquivo ORAAtuTeleSuri.sql
  • 2.2.
    Será solicitado o TNSNames, conforme a imagem abaixo.
  • 2.1.
    Uma vez, realizado o login. automaticamente serão executados os arquivos:
  • 2.1.1.
    ORAAtuTeleDDL.sql, ORAAtuTeleDML.sql, ORAAtuSuriDDL.sql, ORAAtuSuriDML.sql, ORAAtuSynoCau.sql e ORAAtuSynoUsu.sql.
    Obs.: após executar com os usuários suricato e telessvr, não é necessário executar com o usuário sys.


Atualizar Banco de Dados - SqlServer

Instruções para execução dos scripts:
  • 1.
    Os scripts de atualização podem ser executados de duas maneiras:
  • 1.1.
    Somente com o usuário sa
  • 1.2.
    ou, caso não tenha acesso, pode ser executado com o usuário suricato e telessvr.
  • 2.
    Com usuário sa ou privilégios equivalentes:
  • 2.1.
    Executar os arquivos:
    1-MSSQL_DDL_ATU_TELE.sql
    2-MSSQL_DDL_ATU_SURI.sql
    3-MSSQL_DML_ATU_SURI.sql
    4-MSSQL_DML_ATU_TELE.sql
    5-PERMISSAOTELE.sql
    6-PERMISSAOSURI.sql
    Obs.: após executar com o usuário sa, não é necessário executar com os usuários suricato e telessvr.
  • 3.
    Com usuário Suricato:
  • 3.1.
    Efetuar logon com usuário suricato e executar os arquivos:
    1- MSSQL_DDL_ATU_SURI.sql
    2- MSSQL_DML_ATU_SURI.sql
    3- PERMISSAOSURI.sql
  • 4.
    Com usuário telessvr:
  • 4.1.
    Efetuar logon com usuário telessvr e executar os arquivos:
    1-MSSQL_DDL_ATU_TELE.sql
    2-MSSQL_DML_ATU_TELE.sql
    3-PERMISSAOTELE.sql
Obs.: após executar com os usuários suricato e telessvr, não é necessário executar com o usuário sa.


5o. Passo

Descreveremos a seguir os próximos passos para atualização do Suricato, a partir da versão: 2.10.5.5.

Tópico:5o. Passo

Quinto Passo - Reconfigurar Serviços

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Quinto Passo - Reconfigurar Serviços

Descreveremos a seguir os próximos passos para atualização do Suricato, a partir da versão: 2.10.5.5.

Tópico:Quinto Passo - Reconfigurar Serviços

Configurar Suricato Middleware

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.


Configurar Suricato Middleware

Realizar a configuração do banco de dados da aplicação Suricato, conforme a sequência, dos tópicos abaixo.
Configurar Suricato Middleware

Configuração Banco de dados

1. Configuração Banco de dados
Utilize este executável para configurar a conexão do banco de dados.
Topo

© Copyright

Este documento é propriedade intelectual da Telemática Sistemas Inteligentes. Pode ser copiado parcial ou integralmente, desde que este Copyright esteja incluído em cada cópia.